Camera Hacker

: :

Add Comment | Related Links | TrackBack
Related Content

Error Code C:31:40

hi man how are u would u like help
i don't know what to do
Sony_DCR-TRV145. . . When a DV tape is in the camera, an error message flashes with the code: C:31:40. When there is no tape, the error does not appear. I have cleaned the inside of my camera, tried different tapes, disconnected the battery, etc etc etc. yet this message will not go away and I cannot use my camera. Do you have any suggestions as to what I can do to fix my problem?

Wed, 18 Jan 2006 17:46:16 -0800

Quite a few users are having luck by smacking their camcorders. Take a look at this thread and see for yourself: Error Code C:31:23?

Chieh Cheng
Wed, 18 Jan 2006 23:56:42 -0800

Hi had the same problem with a Sony Hi8 from 1998 (c:31:40). The camera was useless.

Ar several forums I found out how to solve it. Hit your camera several times with a flat hand (bottom, tape side). Its strange but my problem was solved. On internet I found maybe 10 or 15 other people who did the same. For all of them this worked fine !


Wed, 22 Feb 2006 11:56:29 -0800

Worked for me... Thanks.. I was bout to pay some service shop do fix it but didn't think it was worth it and checked the net..
Thu, 26 Oct 2006 18:32:45 -0700

I can't believe it but smacking it worked. The recorder kept flashing this code for weeks and I had tried everything in the manual. Nothing worked. Each time that I put in the tape, it wouldn't close and the error flashed. I took out the tape and closed it and smacked the bottom 10-15 times. It worked like a charm! Now we can tape my son's first trip to see Santa. Yippee!

April A.
Sun, 17 Dec 2006 17:52:47 -0800

Sony DCR-HC42 with the same exact problem.
"Whack-a-Cam" worked! Had to do it twice. Seems like something must be stuck in some gears or something. I'm thinking a regular blowing out with some canned air might prevent this.

Tue, 19 Dec 2006 20:59:13 -0800

Error C:31:40 is "FG fault when starting drum". Sony advises to load the tape again. So all of you out there who have been "smacking" your camcorders, do yourselves a favor and stop doing that. You're only making matters worse. One of these days someone is going to knock the tape head out of alignment and end up spending $$ for something that could have been an easy fix.

Sun, 24 Dec 2006 22:42:37 -0800

Well, smacking it worked for me, I guess the head WAS out of alignment and at least for now it works. I agree if you have to do this every time obviously it's not going to work forever, but hopefully it somehow got out of alignment and a slap on bottom corrected it for good!
I'm happy.

Mon, 25 Dec 2006 08:15:46 -0800

Worked for me too. Thank god.

Fri, 05 Jan 2007 22:13:24 -0800

As a professional camera operator with both operator and maintenance tech experience going back to my first 3/4inch vo1600 and betamax 7200 in the late 70s the hitachi sk90 that is responsible for my slouching posture to this day I can tell you one of the dirty little secrets of the hardcore pros is whacking the camera intelligently and judiciously is a common field remedy. If you don't want to look unprofessional carry a small plastic or rubber mallet like the doctor might use on your knee but the flat of your hand is a much better tool. Lubricants dry out in the heat connections expand and contract contamination migrates into the camera with the tape too many more variables to mention here. Bottom line whacking can often dislodge a stuck component in the loading mechanism etc. On a recent episode of a toprated network home makeover show I secretly whacked a pd150 (that was used inside the home under demolition) to make it give up a tape that it wouldn't eject it went right back into combat and performed flawlessly through endless hours of 24/7 shooting. As for error codes they are no more accurate than windows error messages you can get a head drum error code if the loading mech doesn't finish threading the tape. Some of the worst repair jobs I have ever had to deal with were from people who baby their equipment use your gear frequently like your muscles they like it. But never hit your camera in anger just like the real world it doesn't fix anything.

Attached Image:


fred nugent
Mon, 08 Jan 2007 00:24:47 -0800

It worked! Unbelievable! Thanks!

Tue, 09 Jan 2007 11:49:22 -0800

Yesssss this VX200 camera was not working for aprox. a year. I smacked it for 5 or 6 times and it is working again! Unbelievable!
On other forums people are desperate about not finding a solution for the C:31:40 code. Now i found it here tonight.
I am so happy!

Thu, 18 Jan 2007 19:47:42 -0800

This is bizarre but I took my camera in to the shop and they couldn're reproduce the problem. At home it kept on happening. I decided to try and give it a smack. Just a light one. IT WORKED!

Wed, 31 Jan 2007 19:34:44 -0800

Yes!!! I just made all of these tapes in India and wanted to see them. The audio/video was choppy. But after three solid smacks, IT WORKS AGAIN. Thank you.

Fri, 09 Feb 2007 17:58:13 -0800

Tried it with my DCR-PC3E several times - first gently then harder...
No success :(((

Tue, 27 Feb 2007 14:55:40 -0800

It worked!!!!!!!!!!!!!!!! XIE XIE

Joco Pan From China
Tue, 13 Mar 2007 00:53:18 -0800

Sony DCR-HC90,
smacked it 15 times on the bottom lightly as mentioned in this thread.


Tue, 27 Mar 2007 14:41:17 -0800

Had to do it twice(10 taps each) 2nd. time a little more than "light" works so far.Thank you disgrunteled Sony technician.Sony HDR-FX1

Bret in Belize
Wed, 28 Mar 2007 14:07:12 -0800

Wow! Worked.
Use dcrtrv330 with my high school kids.
Smacked one a couple of times(firmly) and it works!

MS in ND
Wed, 04 Apr 2007 09:14:35 -0700

ive tryed this nocking it and taking the battery out and it hasnt worked for me.....i have a sony pd150, can anyone give me and help?

Thu, 05 Apr 2007 18:44:54 -0700


I have an old but still realy good DCR-PC5E. I had the C:31:40 problem. As it would cost a fortune to get fixed I decided to check the net and found this site! Hiting the camera didn't work but using a hair dryer and gently touch the video head fixed the problem!

Thanks a lot for the good advice!
// viking

Viking in Sweden
Wed, 25 Apr 2007 15:19:43 -0700

It worked for me too!

Wed, 02 May 2007 04:08:32 -0700

Well I have a Sony DCR-VX2100 camcorder; I think it doesn't like the smacking very well because I've been smacking it for the last six months without success. I guess I am going to send it in for repair. Bottom line, smacking didn't work for me.

Benoit Nyonga
Wed, 02 May 2007 09:38:58 -0700

wow. my new favorite site- I had just called repair and they were gonna charge me $570 bucks...dang...

Thu, 03 May 2007 09:59:36 -0700

i've got the sony DCR-TRV430E, it keeps tellin me the same error code, and the cam also makes a weird noise from the inside of the camera, when a tape is in.
I'v been recommended on several websites to give it a nice "smack" or some more. I've been smacking the cam for some days, i even throwed it of the table.
no succes.
One website told me to fill the inside of the cam with hot air. from an hair dryer.
No succes

Fri, 04 May 2007 10:23:38 -0700

I am amazed and befuddled. I can't believe it worked!!!!
You don't know what we went through to recover our precious moments from our 8mm's.
I cleaned the camera. We were quoted rediculous amounts of money for service.
I just wished I would've found this tasty tip before spending $800 on a new camera!

Nothin' like fixin' it old school.

Fri, 04 May 2007 21:28:07 -0700

JA JA Ja i cant beleive it, i read this after a few days of trying to solve my problem... code 21 33 in my mini dv hc 30 and as i understood i hit it gently in the tape door, and its working now, ja ja ja thanks its unbelivable!!! excues me for my english!!! Thanks, i saved a lot of pesos!

Mon, 07 May 2007 15:41:13 -0700

I am officially a member of the "C:31:40 Smackers Club". I have a Sony DCR TRV 330 and it tried pulling the 31:40 fast one. But the palm of my hand changed its mind pretty quick. I love getting back at electronics. Don't you?

As an aside, my camera started giving me "the number" when it got jarred a bit. It was in a padded bag but slipped out of my hand and fell maybe a foot to the carpeted floor. So apparently one good jar deserves another. It took a few attempts but it worked.

Mon, 07 May 2007 17:33:09 -0700

It really does work! I was getting the C:31:40: error on a Sony DCR/TRV520, I took it to Best Buy and they said it was not worth fixing and that it would cost at least $60 to look at and probably several hundred more to fix. I found this site, smacked the bottom of my camera and I am back in business!!!

Sun, 20 May 2007 17:08:07 -0700

The smacking doesn't work! I have a Sony mini-DV-cam (DSR-PD150) and it's giving me the C:31:40 message. I've hit it from every angle, but it doesn't seem to do any good. How hard are you supposed to smack it? I'm afraid it'll break, (or I might have broken it already). I tried to take a glance at the headers and the stuff inside. I even slightly wiggled two loose headers with the end of a pencil. *PLEASE* help me on this! It's really getting on my nerves! I desperately need to use the camera!

Fri, 25 May 2007 02:10:58 -0700

I have a cd trv46. it's an older camera and didn't want to spend money on a tech. my italian father in law always fixed his tv by hitting it. i laugh no more.

Sun, 27 May 2007 14:56:43 -0700

I have a DCR-TRV 280. For months on end my camera would give me the "Reinsert the tape" message. So I take the tape out, reinsert it, and of course it doesn't work, it just didn't go back down with the tape in, but with it out it works. But then on some random day it would work, then break, and the cycle would repeat itself. so instead of sending it in i decided to just hit it. It WORKED! It's amazing.

Wed, 30 May 2007 20:14:18 -0700

I had the 31:40 error showing on my VX2100e, took the advise and slapped it, 31:40 error disappeared but now have 32:11 error? Anyone have any ideas?

Wed, 06 Jun 2007 04:16:13 -0700

it worked man! hahahahahahahaha i cant freakin believe it i was sceptical at first but it all went well. alrighty....
open tape housing
Remove tape and close again
turn camera upside down
hit the bottom of the tape housing with force 3 times
insert tape and try

Thu, 28 Jun 2007 01:28:04 -0700

remember to hit it with an open hand!

Thu, 28 Jun 2007 01:28:59 -0700

works fine, thank you very much !!!

Thu, 28 Jun 2007 12:09:41 -0700

My wife just kissed me for finding this forum/solution... because it worked for us too!!!


Wed, 04 Jul 2007 22:44:03 -0700

I dont get this error instntly (DCR-TRV900), only after like 5-10 mins of use (recording or playback) but it gets annoyin, Im gonna try this smacking method. To the people that have fixed their cameras doing this, what am i expecting here> for some piece of dirt to fall off? put pieces back into place or what? or just sheer luck? Anywys wish me luck.!

Sat, 07 Jul 2007 16:35:59 -0700

What a star! Just been quoted �220 for investigation & repair. After finding this, gave it a few hits & looks like it's working fine again. Cheers!

Big Al
Mon, 16 Jul 2007 15:33:19 -0500

i got c: 31 23 and c: 31 :40 with my 4 years old dcr tvr27e
it was the tape , i changed the tape with brand new one

Fri, 27 Jul 2007 07:18:32 +0000

Thanks for the great "money saving" advice...changing tapes, batteries and cleaning didn't work for me...10 smacks and I'm good to go...

Bob Mc
Sun, 05 Aug 2007 21:52:15 +0000

I am a private investigator and have had and currently have about 8 of the Sony cameras. I just fixed my trv-530 tonight. Constantly got 31:40 to where I couldn't trust any longer. I removed every screw in the cameras body, banged it around a few times, put it back together and hard as I try can not make it not work. Thanks for the advice. I didn't read about banging bottom until after taking apart. Thanks for the great and money saving advice.

Sat, 18 Aug 2007 03:49:38 +0000

It worked for me too. Thanks everybody.

Another satsified user
Sun, 19 Aug 2007 15:14:35 +0000

I can't believe it!!! Smacked it 10 times on the tape door and out popped the stuck tape. Wish I would have read this thread two hours ago!!

Chuck O
Tue, 21 Aug 2007 23:30:04 +0000

I am shocked. It worked for me too.

I have the SONY VX2100 and use it for my media training business. It worked the last time I had it out, then at my next training stop, it started flashing that. Fortunately the team I was visiting allowed me to use thier camera. I was off to my next training today when I went to a camera shop, they couldn't figure it out, and I entered into Google. This forum came up, and I was very skeptical, but desperate. I whacked it 15 times for good measure and to vent frustration, and I'll be's working.

Thanks all!

Fri, 24 Aug 2007 18:00:06 +0000

Sony DCR-HC42. Five whacks.

Tue, 18 Sep 2007 02:26:53 +0000

Sony DCR-TRV340
smakcing it works for me too, however I have to do it almost evertime I turn off my camera and want to to turn it back on.

Ben Muzzer
Thu, 27 Sep 2007 17:19:48 +0000

Slaping TRV 210E 3times series of three..... And worked out well.

Sat, 06 Oct 2007 17:08:00 +0000

I cant believe it. It really worked! I thought this was some kind of joke but I figured " what could I loose" the camera is broken anyway. Thanks alot!

Sun, 14 Oct 2007 16:59:51 +0000

I was incredulous when I read all these comments about smacking the bottom of the camera, but I tried it, and it worked!! Thanks everyone.

Happy girl
Mon, 15 Oct 2007 21:31:29 +0000

Holy Cow...2 smacks and it worked....

Sat, 20 Oct 2007 09:26:27 +0000

Haha I found this camcorder next to a wall! Sony DCR-TR7000E and it works,
and so i got some Hi8 tapes and got this C:31... msg
Looked online, found this page and smack!
Worked! Thank you internet :)

Luke Mundy
Thu, 25 Oct 2007 14:37:36 +0000

TRV330 Error Code 31:40
Worked all day trying to fix the problem with the help of the manual
Finaly, checked online for some advise.

***10 gentle smacks...guess what...IT WORKED!!!!

Many thanks!!!! That made my day......!!!

Sun, 28 Oct 2007 23:15:06 +0000

I had this c:31:40 problem recently with a Sony z1. Guess what? IT WORKED.
10 smacks were enough.
I'll try it with my wife as well ;-)

Rudy from Belgium
Tue, 13 Nov 2007 09:18:28 +0000

Isn't this cool. Worked for me too. Thanks to the Sony camera we've made the world a much smaller place :)

Linda from US
Mon, 03 Dec 2007 15:35:54 +0000

wow....bad cam gets smacked.....
works fine now....

Sat, 08 Dec 2007 20:06:01 +0000

2year old SONY HCR-42 on clearance $200.00......

Access to Google to find this site at work $0.00......

Calming a hysterical wife over the phone by telling her she can hit the
malfunctioning camera several times, getting it to work so she can
film our 4 year olds Christmas Show at school....PRICELESS!!!!!!!

Fri, 14 Dec 2007 14:49:54 +0000

ho un problema con la mia splendida videocamera sony DCR PC9E.
funziona tutto senza cassetta, appena la inserisco mi da errore c:31:40 !!!
Per favore qualcuno mi puo' aiutare, a risolvere il problema !!!!

Thu, 07 Feb 2008 19:14:01 +0000

A DSR250 just arrived with the dreaded C:31:40 error message. I'll post results as soon as i finish fixing it.
Just so you know, a 250P is a professional cam, not your average-dubious-homemade-movie-handycam type of thingamajig.

Nikky Fade
Fri, 15 Feb 2008 10:56:34 +0000

Thanks I just got done cleaning my trv 520 trying to fix the problem but after smacking it on the bottom it worked great.

Jon Kiger
Thu, 21 Feb 2008 10:07:17 +0000

I have a Sony DCR HC42E which was showing the error message C:31:40. I was about to send the camcorder to Sony, thereby agreeing to pay �176 to have it fixed, when all it needed was a good smack! I didn't believe it at first but thought it was worth a go. It didn't work with the tape in but I took the tape out and whacked it on the bottom 5 or 6 times with my hand and now it works again. Brilliant.

Mon, 03 Mar 2008 20:45:08 +0000

That shit doesn't work. It sure doesn't work for me. The best solution? Stop buying goddamn sony cameras.

Thu, 06 Mar 2008 02:33:26 +0000

IT REALLY WORKS but you have to hit it a bunch of times i almost bought a new camera i wazs so upset when it broke thank u so much for posting it rlly rlly helped

this relly works!!!!
Wed, 12 Mar 2008 04:13:48 +0000

Amen! My Sony TRV280 was ejecting tapes, but couldn't load it back! After reading this post I smacked it few times and it works like a charm! Thanks guys! Now I can sell it on Ebay!!! :)

Sat, 15 Mar 2008 14:22:38 +0000

Man, I smacked it a few times and it works. I had to take it twice to a rapairman, every time it worked for about 3 months. Than it stopped and the bloody error appeared again. Now I am a proud smacker:D hehehe:D I live in POland and I spent about 400zlotys for the rapairs (about 200$) and all I needed was a little smack! The guy replaced 3/4 of the inside, but the solution is so simple:D But I don't think the cam will work forever, so we have to come up with annother solution. I tried to look at the mechanizm that ejects the tape, but You cannot see everything without tearing everything apart. Suggestion - throw Your cammera away and buy annother one (not Sony)

Tue, 18 Mar 2008 15:31:51 +0000

It worked!! Here with my uncle over from the States, he was bullling that all the shops here are closed for the bank holiday, but it works!!!!

Tue, 18 Mar 2008 18:32:40 +0000

The C31:40 error drove me crazy for sometime now. I tried everything I could think of. I read few postings on the net about some humidity issues, so I kept the tape door open for hours without any luck and then I came across this listing, but at first I was like, no way this could work. but then I thought to my self, what the heck, what am I going to lose, I was ready to send it to a Sony service center so I smacked the cam with the bottom of my hand for like 15 times and holly cow, it worked!!!!!...
Thank you all for saving me a trip to the service center and save me $$$ ...

Tue, 25 Mar 2008 22:43:33 +0000

I have a DCR-PC103E Sony MiniDV Handycam. It started showing the C:31:40 code just a couple of day into our summer holiday last year. Result: no summer holiday video. It would let me eject the tape but would never take the tape back in properly. So you could not reload the tape as Sony suggests, in order to solve the problem. Likewise, new tapes didn't work, nothing worked. Then, the camera started working again, miraculously. Then it was back to C:31:40. Tape in and out, battery on and off. Cleaned inside. Still failed to work. Several weeks later, picked it up out of the blue and it miraculously worked. Christmas: camera's back on C:31:40 again - no video of kids at Christmas....

I was just about to get a quote from a repair place when I came across your site. Slapping it with the tape still inserted did nothing. Just more C:31:40 messages. However, after slapping it with the tape ejected it worked fine. I am soooooooooo pleased. If only I had known this a year ago!!!! Just five gentle steady slaps on the bottom and it's as good as new again.

Thank you thank you thank you.

Thu, 17 Apr 2008 20:34:27 +0000

C:31:40 code made me crazy for weeks with my DCR-HC90E.
I tried everything: Batteries out, blow out with dry air, handle everything smoothly.... nothing worked.
After 10 smacks with inserted casette it worked fine!
Thank you very much!!!

P.S.: I had the same issue with an old CD player 15 years ago. Before throwing it away I smacked it 10 times and shaked the whole player like a drink mixer.
After that the player worked fine for 10 more years with no problems.
If I would have had not that experience, I could not believe this. But....

Michael Switzerland
Sun, 20 Apr 2008 12:29:01 +0000

Hi my name is Israel'm Brazilian I'm having a problem in my Cam sony tvr240 The only lower compartment of the tape without the tape and the tape he did not lower! In the display appears the error C 31:40 You can help me or give me someone who can?

Israel Winter
Tue, 29 Apr 2008 14:16:58 +0000

I had this error code (c:31:40) for a month, I smacked the camera a few times, but it didn't work immediately, I shook it to see if there was something stuck somewhere, and guess what? the smacking (gently though) got out the little round thing that helps spin the tape, It was stuck somewhere, I got it out and just put it back where it should be. It worked, it really did, but it has to be a very gentle smack so you don't mess up other things. When you smack, turn the camcorder upside down to see if something falls off from it. THANKS!!!!!!!!!!!!!!!!!!!!!!!!!!

Sun, 04 May 2008 17:07:49 +0000

dcr sc100e, 2 sets of 15 slaps and error 31 42 is gone.
thank you

george lazenbleep
Mon, 05 May 2008 13:45:30 +0000

Just a couple sharp smacks with the tape out and c:31:40 was toast

Tue, 06 May 2008 01:42:00 +0000

I wacked my sony handycam and it now works!!!!
The head was out of alignment, sony website wanted $200+ to fix it.
I found your website and WACKED IT!! Just two times with a flat hand on the bottom.
You completely SAVED me!

Fri, 09 May 2008 14:05:04 +0000

On vacation it stopped working. The tape wouldn't go in..Got home found this. It took a few times on the bottom but IT WORKED. Too bad I didn't see this on vacation. thank you.

Fri, 09 May 2008 18:03:45 +0000

Second time I get this problem C:31:40.First time spent around $150 us to get it repaired. I've just come back from Mexico and wanted to see my film. Again the same problem; I'm furious. Went on this site, read the "instructions" slapped it twice behind the battery and twice underneath and works !!!!!!!!
Just cant believe it. Thank you internet !!!!!

chris paris
Tue, 20 May 2008 15:37:39 +0000

smackin the camera then taking out the battery worked great for me

Sat, 24 May 2008 01:02:36 +0000

smackin' the underside works. Thanks

Sat, 24 May 2008 22:02:03 +0000

That's totally messed up! I have a Sony DCR-HC32 with the C:31:40 error. First problem I've had in 3 years. 10 medium whacks on the bottom without the tape in & I'm back in business. Pretty weird.

Mon, 26 May 2008 04:11:55 +0000

That was very scientific! I made an internet search and the results say that I should smack the device! Worse was yet to come: I smacked it, nothing happened, smacked it again, hey it's working!!! :)))

Sat, 07 Jun 2008 08:41:04 +0000

funny.....i did what you guys said....i WHAKCED IT......IT WORKED...THANKS!

Sat, 28 Jun 2008 03:41:08 +0000

The incredible benefit of the WWW ! I too had an oldish but perfectly servicable SONY DCR-PC5E..until it stopped working at,(Wouldnt you guess), a critical moment when I needed it.... The following day checked on the web, found this site and tried a couple of smacks...with the tape OUT.
IT REALLY WORKS! Thanks to everyone who took time out to record how to do it.

david dore
Mon, 14 Jul 2008 09:19:11 +0000

Wow... GOD IS GREAT!!!, I didn't want to do it but my brother convinced me to. I hit it not so hard, not so soft 15 times without the tape and then i put the tape in and it worked!!! i could finally watch some stuff i couln't before. Thank's so much!!! VIVA MARIA.

Tue, 22 Jul 2008 05:50:09 +0000

I have a vx2100, showing the error code c31:40, did a search and came here. I thought it was nuts, but being very frustrated, I hit my camera 4 times and it still didn't work. I hit it a few more times, still not working. I hit it harder and a few more times, getting close to 15 hits, and LIKE MAGIC my camera is working fine!! Thanks

El Roberto
Fri, 25 Jul 2008 23:04:37 +0000

Hello today I was in a panic. This message re insert tape showed up on a couple of my camera's before and I was blessed with another one. Now my new camera is digital and I just got the re insert message again. I really need this footage for a client. After reading this help board I thought you guys were playing about smacking the botton of the camera with a flat hand. I said to myself people need to stop joking because this is serious I need my camara. As silly as it sounded I was in a bind so at this point I would have tried anything. I prayed took the tape out smacked it twenty times with a flat hand and now it's working fine!! Thank all of you!!

Joe'i Chancellor
Wed, 06 Aug 2008 15:21:56 +0000

am i the only one then?

if have the DCR-HC22E
we bought it on 06/02/2006 for a long vacation but we never went and only used the cam for less then 30 minutes taping (nothing wrong)
but now more than 2 years later, we want to use him for the second time and now he gives also C:31:40
but the problem with my cam is that the insertsleeve will close without a tape but when i put in a tape he only closes half and then the C:31:40 code appears

i did try slapping soft/hard and at all sides of the cam but nothing works!
i really hope that someone nows the awnser for us
we want to use the cam for on of the greatest moments in our life THE BIRTH OF OUR FIRST CHILD and i hope it will be solved soon because se has to give birth within 2 weeks!!

please someone help us

Maurice Kempers
Tue, 19 Aug 2008 20:40:16 +0000

Astonishing :S
Such an old fashion handling of machinery still works ;)
Too bad this error appeared during my holiday and unfortunately this trick didn't occur to me.
So only the first day is on tape......
@home i read this solution.....only 5 seconds later i had a fine nice working piece of machinery which provided me pleasure already for the last 9 years....hope it will continue working for another 9 years :P

Fri, 22 Aug 2008 10:19:07 +0000

AMAZING,playing with this all day trying to get the tape to go in,started surfing the internet and saw this article,one wack and it is working,I have lots of cameras and always take very good care of them and when traveling pack them like they are fragile as an egg,that is why I could not figure why it was not working,I am so careful,OMG,one wack!!!!

Fri, 29 Aug 2008 21:27:43 +0000

Don't tell the Vulcans.... despite logic, after a month of not working, the 10 wack method worked on my DCR-HC39E managed to retify the non tape load problem and gone now is the error

Sat, 30 Aug 2008 17:38:22 +0000

I have a hc96. I have been using it for a helmet cam for MX. I was going to use it this weekend and after I got it set up it started to flash c:31:40. I read this forum, removed the tape, closed the door and gave it 4 solid hits to the bottom of the camera with my palm. I opened the door. It made an unusual noise as the tape carrage came up. I put the tape in and it works fine. Thanks!!!

Mon, 15 Sep 2008 05:52:36 +0000

You have

any. Problems in Sony camera
pleas contact me

sarath c pillai
Wed, 17 Sep 2008 06:00:16 +0000

Wonderful! I also worked for me... Slap (gently) your cam!

Sun, 21 Sep 2008 13:57:29 +0000

so...where did you guys hit the camera? the bottom or the tape deck side? and whats the deal with hot air?

Mon, 13 Oct 2008 23:16:40 +0000

I also had the C31:40 error code on my DCR-HC42E. Just before I took it to the shop I found this site. 3 gentle smacks on the bottom and the problem was solved! Life would be interesting if women gave an error code when they had a problem and that you could fix it with some gentle smacks on their bottom :-)

Fri, 24 Oct 2008 13:18:39 +0000

OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!
OMG - It just worked !!!

Brian Watson
Sat, 08 Nov 2008 04:29:00 +0000

I had the problem C 31:40 in the DCR-TRV17 and reading this page.. it worked..

Sat, 08 Nov 2008 16:55:12 +0000

Yeaaaaa, I hit my camera on the bottom ---- it worked again!!!

Fri, 14 Nov 2008 19:16:01 +0000

It worked on my DCR-PC101 !!!

Spanking is good!

Sun, 30 Nov 2008 15:35:17 +0000

Thank you so much, it works.

Wed, 31 Dec 2008 04:47:16 +0000

It's unbelievable!!!. It works after some hits. I had a week attempts according to the manual, without result.

Tue, 06 Jan 2009 19:29:54 +0000

I had the dreaded C:31:40 and now I'm a smack-a-holic! Let's hear it for Old School!

Thu, 08 Jan 2009 21:57:26 +0000

Tengo una DCR-TRV230, presentaba el error C:31:40, la golpe� apagada en la casetera y el problema desapareci�.

Wed, 14 Jan 2009 02:03:21 +0000

I have the DCR-TRV720 with the C31:40 problem, called Sony they wanted $401.00 to check and repair the camera, what do they think I'm NUTS. I did a search, found a way to relieve stress from my broken camera and that is to do the TECHNICAL SMACK DOWN a few times with my fist, it works great. Nothing like taking matters into your own hands.

Fri, 06 Feb 2009 00:09:41 +0000

A TRV351 with the same problem. Attached to the carrying case a note: "this camera has been repaired 2 times,
please be careful with this machine". Haha, guess what.
The doctor hit it ONCE, pretty hard. No more beeps and flashing error codes. Next patient please.

I'd better change the note to: "camera repaired 2x by
Sony, and hit 1x by me. More cameras welcome".

Sun, 15 Feb 2009 15:59:41 +0000

I have had exactly the same problems with my DCR-VX2100E and the 31:40 warning. Well, I just did the whacko thing a few times on the bottom, but it didn't seem to do it. Then I did what the one guy suggested, whacking it from the back where the battery is. Guess what? It works again! I kind of have the feeling that whacking with your hand from battery end is the better method. Good luck to you all! David

David Q
Tue, 17 Feb 2009 17:45:17 +0000

I am a private eye and own 5 DCR-TRV320 Handycams but I could not solve the mystery of the flashing C:31:40 that has plagued two of my units for well over two years. Thanks for the hard love advice! Now both units are back in action!!!

Ben M.
Sat, 21 Feb 2009 10:20:30 +0000

OMGGGGG!!!!!! I cannot believe this at all, we havent use the camcorder for about 2 years now today I was looking on the net and found this absolutely fabolous site and said WHack a Cam jajaja IT REALLY WORKSSSSS!!!!!!! thanks to everyone i will be keep looking!!!!!

Im from PR( Puerto Rico)

beautiful gril
Sat, 21 Feb 2009 21:28:32 +0000

it's stupid, but smacking the part helps. at least i removed the tape before and gave it some moderate hits. thanks for the good hint

goetz von berlichingen
Tue, 10 Mar 2009 12:31:12 +0000

�Gracias! Lo le� y no lo cre�. Como ya no me estaba funcionando, �qué m�s pod�a perder? Funcion�, as� que inténtenlo. �Gracias nuevamente!

Fri, 17 Apr 2009 22:20:33 +0000

SONY DCR-TRV25 brought in 2003 and was not used for a long while.

Without a tape, the compartment runs fine . But with a tape inserted, it can /barelyfully close the compartment door, but it would not "go down", and at the same time it show C:31:40 code.

Try the smacking and it was NOT working for me. Try the hair-dryer, and it was NOT working either.

As mentioned in an earlier post (great thanks!), I used the "pencil's eraser end" and reached the drum and gently move/push the drun a bit with very very gentle force. And then it worked right after!

Just another possible way to give it a try...

Mon, 27 Apr 2009 03:11:01 +0000

You slapping fools!!!!

The problem is a rubber tape tension er. Simply eject the tape, look inside where the tape goes. You will see a black rubber cylinder that may have a white plastic tube protruding. If you have long tweezer or a hemostat remove the plastic tube which hold the rubber tensioner in place, then remove the rubber tension cylinder. Clean the shaft of the black rubber tensioner with alcohol on a q-tip. Replace rubber tension cylinder and plastic tube.

Also, the tapes can cause the problem. This process is possible by one person, but you may need another person or have three hands. The C:31:23 is tape tension error. The tape has become stuck. Simply eject the tape. Holding the tape upside down, pull back on the tape cover release slide on the left side of the tape, now take the hemostat and push the tape release tab, located opposite of the tape cover, push this tab down and back toward the back edge of the tape. Now while holding both those release levers, take a pencil and wind the tape past the bad spot or until the tape winds freely.

I did both of these and was able to use the camera again and view all my tapes!


Sun, 17 May 2009 15:59:59 +0000

Have a DCR-TRV310E and had the dreadful 31:40 error. Not only that, but also had the grey stripes across, indicating the head needed cleaning. Five smacks with a palm to the bottom and camera is back in action!! No more messages, no more grey stripes!

Thanks to all for this solution!

Sat, 30 May 2009 11:34:59 +0000

I have a DCR-TRV330. Initially the tape got stuck in there and doesn't come out. Forgot the error code at the time. Then somehow I got the tape out. After that, I cannot get the tape back in there, there is always an error code C:31:40 when I try to put the tape back. I saw this message thread and did the 5~6 times smack at the bottom when there is not tape in there but battery on, and IT WORKED! It would have costed me $200+. Thanks a lot for everyone's info sharing. And Sony customer service sucks!

Mon, 08 Jun 2009 05:38:18 +0000

c:31:40 keeps coming up. Smacking the camera on the bottom and sides, works sometimes, but the problem comes back again and again right afterwards. i tried using a hairdryer and gentely moving the

Wed, 24 Jun 2009 18:14:11 +0000

Guys, I got the same error meesage,c31:40 I was about to start packing my sony supershot camcorder i purchased in 1998. Something told me to check the error message on the internet, so did, And, it Worked For Me Also. I hit the bottom side of Camcorder gentley few times and, the on the tape cover side also. Thanks for the posting. Good Luck everybody for saving me $216.00

Dinesh A Salian
Wed, 24 Jun 2009 23:46:51 +0000

I have a DCR-TRV260 that displays the C:31:23 error. I have smack the camara but istill does not work. I took a look inside by the black rollers (looking at them when the door is torward your ching, then this would make the right side roller)and found that there is a (White) plastic part that is tied to a thin metal strip that looks like is some type of spring tensioning. I am not sure where does this part is secure to or how to roll the spring to the correct tension.

Thu, 25 Jun 2009 17:26:48 +0000

i have just repaird my HDR-FX1E the tape loader was put new when i got it 6 months ago it was alright i have only used it in 6 months about 3 times now i am getting the error message reinsert tape with a 31-23 message can anyone give me an idea of this can i fix it at home or take it to the dealer again thank for your advise.

manuel martinez
Sat, 27 Jun 2009 07:24:03 +0000

It worked for me as well!!! Tapped it just twice gently and it started working...I was almost in the verge of buying a new one...Thanks

Mon, 13 Jul 2009 00:52:46 +0000

Sony HVR-Z1, does the same errors as above, C:31:22 I looked into more in depth and mine seems to manage to work every now and then, but I did more tests and realised, the error kicks in every time I hit the fastforward button, not on rewind, and is more promimenant with MiniDv's than DVCAM's. Anyway, I was told by Stanly Productions its the tape carriage needs repalacing. Now I am worried, as I don't think this is the problem. I did smack the Z1 a couple of times and sometimes it worked and some didn't. The last thing you need is for your clients to see you smacking the camera before a shoot.

Tue, 21 Jul 2009 16:56:50 +0000

Sony DCR-TRV11 10 whacks, works perfect now thanks!

Thu, 23 Jul 2009 22:06:33 +0000

Looks like,.....smacking the side still ""WORKS"" for C31:40 error.

Biju C
Thu, 13 Aug 2009 17:29:21 +0000

DCR TRV7E - Took a while and probably more smacks than I thought would have been healthy for the camera but it does seem to have worked ...

Thu, 20 Aug 2009 08:39:43 +0000

thanx, it's working like magic after smacking it 4-5 times with arabian sandals

goodluck guys

Wed, 02 Sep 2009 10:50:28 +0000

Worked also with my DCR HC39E. Thanks a lot!

Wed, 16 Sep 2009 19:08:06 +0000

SOB!!!! This worked!!!!SONY TRV 350!!!! Thanks for old threads!

Wed, 16 Sep 2009 21:56:27 +0000

I had a similar problem and whacking worked to start with, but then found the rubber pinch roller had moved up the capstan - whatever holding it in place was gone. so I found a piece of electrical insulation that was a snug fit over the inner shaft and pressed it on, holding the pinch roller in place. This has worked for a year, but then C:31:40 came up again so I checked the pinch roller and it had ridden up just enough for the camera to complain about tape alignment again. A gentle push down and it is all good again.

Thu, 17 Sep 2009 11:33:29 +0000

I thought this page was a joke, camera was completely unoperational, 3 hard smacks on the like butter. THANKS!

Wed, 14 Oct 2009 16:11:11 +0000

PCR-DC55E....I smack it gently few time and it work again, but several time the problem come again and must smack it again and again............I'll try with the hair drier. Wait for the report

Thu, 15 Oct 2009 02:04:02 +0000

Con una sony DCR-255E ha funzionato.
Ci sono voluti diversi colpi sul fondo della videocamera chiusa senza cassetta.
Prima davo dei colpi col palmo della mano tenendola con l'altra mano.
gli ultimi 2 li ho dati con la videocamera poggiata sulla scrivania col fondo rivolto verso l'alto e chiuso...apro metto la cassetta e MAGIA !!!
Non vi scoraggiate al primo tentativo...ovviamente no distruggete la videocamera...dei colpi a mano ferma...buona fortuna!!

Sat, 24 Oct 2009 15:07:21 +0000

Hmm.. started to read the page, couldn't believe it to be that easy. We are talking about not being able to watch the films of the kids from their birth 13 years ago.

Tried it - and IT WORKED!

By the way, I have a Sony DCR-TRV240E


Patrik Berglund
Sun, 25 Oct 2009 18:59:53 +0000

i have sony VX-2100 still this problem i smack 15 times my camera, but same error C:31:40 pls Help

Mon, 16 Nov 2009 19:46:00 +0000

Are you fucking serious??!! I smacked it on it's ass 15 times like a little kid and now it works!! DO IT NOW!!! but remember there is a difference between discipline and abuse just tap it medium...

Thu, 19 Nov 2009 07:47:08 +0000

Gente! Estuve buscando la posible solucion y llegue hasta aqui. Tengo una Sony HDR-HC5. Mi error fue C:31:40. He intentado hacer lo de las "palmaditas" en la parte inferior de la Camara pero NO funciono.
Llevo 2 a�os y medio con esta camara y es la primera vez que me sucede...No se que hacer, pero si la envio a algun tecnico, seguro que me asesinan con el precio!
Tratare de buscarle la solucion. Si la encuentro les aviso!
Saludos desde Argentina!

People! I was looking for possible solutions and come up here. I have a Sony HDR-HC5. My mistake was C: 31:40. I tried to do the "pat" or "hit" at the bottom of the camera did not work.
I have 2 ½ years with this camera and is the first time that happens to me ... not to do, but if you sent some technical, kill me for sure with the price!
Case of seeking a solution. If I find them notice!
Greetings from Argentina!

Sun, 06 Dec 2009 15:16:28 +0000

Nuevamente el del Post anterior (de la Sony HDR-HC5)...SI, apenas unos minutos pasaron y "voila!" ASUNTO ARREGLADO!
Dios m�o!!! NO PUEDO CREERLO!!! FUNCIONO!!! ALELUYA!!! Es incre�ble...Le di 3 golpes cortos con los dedos sobre el costado donde se inserta la cinta y funcion�!
Mil gracias por este post! No lo olvidaré!
Esperemos que siga funcionando porque la necesitamos para trabajar!!!
Desde Argentina!

Again the previous Post (on the Sony HDR-HC5) ... Yes, just a few minutes passed and "voila!" ISSUE FIXED!
My God! I can not believe! FUNCIONO! HALLELUJAH! It's incredible ... I gave him 3 strokes short fingers on the side where you insert the tape and it worked!
Many thanks for this post! Do not forget!
We hope to continue working because we need it to work!
From Argentina!

Sun, 06 Dec 2009 15:35:15 +0000

I'm amazed. My DCR-TRV17 works again. Just one light tap on the bottom of the unit and the tape loaded in with no problem. I'm now looking at a tape that was recorded in 2001 that I haven't been able to view for years!! I guess lubrication might have helped the tape transport loosen up but this is all it needed. And I was wailing at the thought of spending $371 flat rate fee to have it looked at by the SONY repair specialists..... Thank you, from the bottom of my wallet!

Sun, 13 Dec 2009 22:35:42 +0000

UNBELIEVABLE!!! A few smacks and it worked! Thank you soooooooooooooo much!

Sun, 27 Dec 2009 20:46:15 +0000

Sony TRV900 here... And it worked ! Unbelievable. ^^;

Tue, 19 Jan 2010 14:19:09 +0000


I had the 31:40, too.
Then I read about the spanking therapy.

First it didn't work. Then I hit it again.
4 times, pretty firmly, and -TADAAAAH!!
It works again!

I still can't believe it. It works again!

Martin, Neo- Whacker
Sat, 23 Jan 2010 00:06:43 +0000

try to reset it. it worked for me, don't hit it! :)

Wed, 03 Feb 2010 16:55:26 +0000

Many thanks! My Sony HC-90 working again!!

Sun, 07 Feb 2010 21:48:21 +0000

Sony DCR-TRV103: C:31:43 problem
had this problem for years, only now did I made it work via the "slap treatment" which could have cost me $$$$ taking it to the SOny service center. Now I can watch our old videos....Thanks to this thread!

Sun, 14 Feb 2010 16:54:02 +0000

Holy s*%t, my camera Sony dcr-trv330 had a c:31:22 error code with the eject symbol and hitting it like everybody else worked!!...hahaaa....for once hitting an electronic device actually worked....this is so funny.....I don't know if that means Sony makes crappy electronics or what but I can still use my camera....thanks for the advice!!!

Tue, 23 Feb 2010 01:34:54 +0000

After the SLAP treatment STOPS FIXING the problem, hit eject, remove the tape. Look for the two pegs that spin the cassette wheels(they're white in my model). Reach in with finger and try spinning them. They should spin freely with the cassette out. One of mine was spinning freely the other wasn't. I twisted the stuck one a little harder until it started spinning freely. NOW IT WORKS!! Again!! We'll see how long that lasts. Hopefully long enough to get all my tapes onto my hard drive. NO MORE SLAPPING FOR NOW!!

Brian McRorie
Sat, 27 Feb 2010 21:17:30 +0000

M�me probl�me code C3140 caméscope Sony TRV-310Ee en voyage au LAOS en février 2010 apparition du code C3140 � chaque chargement de la cassette impossible d'enregistrer ou de lire, au retour apr�s recherche sur internet je suis tombé sur ce site et apr�s lecture des différents messages j'ai effectué la man�uvre décrite soit quelques tapes sur le fond de l'appareil et au niveau de la batterie avec la cassette enlevée et miracle disparition du code C3140 et l'appareil fonctionne de nouveau correctement.
Merci � tous

Sun, 14 Mar 2010 10:47:26 +0000

Wish I would have found this site before I spent $129 at a pawn shop buying a replacement to my DCR TRV 460, that didnt work. Apparantely, the older one I got at the shop has a different recording speed (fps). But, as I was ready to give up all hope, I found this site, smacked it several times on the bottom, and it works perfectly!!!!

Wish my wife worked this well when I smack her (lol, jk)

Eric McCowan
Fri, 30 Apr 2010 16:46:22 +0000

Code C:31:40 The probelm is not with the Cam. It's with the sorry Sony tapes.
What I did,.....behind the mini casette there is a square hole.
With a pen....push towards edge, with a pencil.....start turning tape to get
started.....about two try it

Mon, 17 May 2010 17:24:56 +0000

Superb advise. Camera left as faulty for several months. After smacking, finally able to tranfer Mini DVs to mp PC

Many Many Thanks

Wed, 19 May 2010 13:23:34 +0000

All I can say is...Wow! My camera has been toast (so I thought) for a few years now and I decided to tinker with it again before selling it on Ebay for parts. I came across this thread, smacked the crap out of my camera, and now I'm watching old videos of my daughter.
Thanks to all who have contributed to the thread!


Sat, 29 May 2010 18:19:49 +0000

Holy cow I hope this works, my 2 1/2 year olds very first dance recital is tomorrow night and we haven't use the handycam since Christmas thinking it was broken and thinking we had to buy a new one we had error code C:31:22 and kept thinking it was bad batteries... and decided to search the error code... we are going to have to test it as we would be using it for 10 minutes or so and then boom the error code.... so fingers and toes crossed that it works.

Wed, 02 Jun 2010 23:51:13 +0000

for 2100e found solution. When start eject tape start many hitting camera in bottom side, after 5 time cassete ajected.

Fri, 02 Jul 2010 10:16:40 +0000

My camera wasn't pulling the cassette all the way in, so after panicking, I googled for help, got the advice to smack the camera...well since I have no other options I tried it. I can't believe it...smacking the bottom of my camera totally worked!! Unbelievable!

Melissa porterfield
Mon, 12 Jul 2010 01:20:22 +0000

I have a HC3 which also decided it wasn't going to load / unload tapes. Very frustrating. I tried beating the living daylights out of it (almost) and that didn't work. I tried the reset idea, combined with prodding, poking and whacking - but nothing.

So I finally decided that I have nothing to lose by attempting to craft a DC voltage source to reset the motor as described in this forum. It really wasn't as intimidating as it appeared for a "no-no" like myself. And Voila! I actually managed to do it and it worked!! I got the motor to wind the tape tray all the way up, plugged it back in, inserted a tape, and that was it!

Thanks to everyone here and especially the forum webmasters for helping me get this fixed!

Thu, 05 Aug 2010 16:37:52 +0000

One more succesfull story with Sony DCR-TRV900E

Tue, 24 Aug 2010 12:36:25 +0000

Unfreakin'believeable! I got the C:31:40 and then the 31:23 error on my Sony DCR-PC120 NTSC camcorder and the thing simply would not work. Then a friend told me to Google it and viola! up came this site. I read most of the comments. So I decided to take out the tape and smack the cam a few times, didn't work, then I did it again and still didn't work.
Then I took the canned air I have used to clean keyboards etc. and gave it a good blowout. And it worked!
These forum sites are awesome man,I pretty certain I saved some bucks! thanks to everyone!

Anil J
Fri, 08 Oct 2010 20:04:51 +0000

Ok this is totally crazy!!! I took a 3 week road trip this summer with my kids and had them video record. Along the way. got home and the compartment wouldn't eject tape. - Sony dcr-tr17. I felt sick. I have tried to get it out since august and was ready to take it in and i came across this forum. smack it - guess at this point what do I have to lose. Smack it 2x and my camera beeped and the tape ejected!!!!

Sat, 16 Oct 2010 22:34:07 +0000

I've tried differenct ways of smacking it until it worked -with/without tape, bottom, sideways, turned it upside down. The effect was different - at first nothing ( I was smacking it too gently, I guess), then it started working but with some strange noise. Anyways the best way it worked out for me and you may use is:
take out the tape
hold it still
smack it underneath 4-5 times 50-60 % of the all strenghth you might have (careful but not too soft)
If it doesn;t work, do it again.
Then again.
Believe it or not - for me it worked out just's a SONY DCR-HC38 miniDV handycam which stopped working while I was filming underf heavy tropical rain. Good luck to all!

Thu, 18 Nov 2010 06:21:59 +0000

I was skeptical...but it worked. Three good raps on the bottom. I heard the tape tray spin for about one second. No more problems. Amazing!

Sat, 18 Dec 2010 19:10:58 +0000

YEP! Gave it a Smack-a-roo a couple of times and it works fine. Gotta wonder about the guy that would try smacking a $1100 camera to get it to work though. :o)

Wed, 29 Dec 2010 19:25:46 +0000

I had the famous C:31:00 error code - on my Hi8 Canon camcorder the tape would not go down into the camera after I pushed the door closed. I read this forum. I left the tape in, the camera on, and gently whacked the bottom of the camera (front-end) onto my hand. On whack #2 down the tape went into the camcorder - it has worked fine ever since. As my father once said "Lots of contraption in there" Well, this contraption liked a little whack. Thought this unit was a gonner, too old to pay to fix. Try it; odds are it will work.

Cannot Believe It Worked
Thu, 30 Dec 2010 19:32:46 +0000

Unbelievable, it worked! Been like this for months, and now were back! Thanks everyone...

Tue, 11 Jan 2011 22:49:41 +0000

It worked for me. They should re-write the operating instructions to include the cam-smacking procedure!

Fri, 28 Jan 2011 17:27:38 +0000

Great ! Worked for my handycam sony PC 1000 .

Fri, 11 Mar 2011 18:08:06 +0000

Still works on the old Handy Cam. Recorded a hole tape think just the view finder was messed up. The Handy Cam Recorded this horrific video looked like some sort of sepia filter. Smacked the little guy a couple times, and to my surprise back to new. I wonder if this works on other things??Like the car?

Thu, 21 Apr 2011 04:06:26 +0000

it still works 10 year mini cam a few whacks after 3 years not in service and back at it

Tue, 24 May 2011 01:08:18 +0000

Unbelievable! My Pdx10 worked flawlessly for 6 years, but got stuck this morning with c:31:42 error message. Despite several hours of changing tapes and/or batteries, opening tape door open to dry, moving spindle to different position, it wasn't until trying the whack-a-mole technique, that it started working again. Who would thunk it?

Fri, 27 May 2011 22:57:19 +0000

Wow. I went through the manual and there was nothing in it that helped me. So i found this thread and tried the smacking technique. It took 2 separate tries (I took the cassette out before the second try). About 12 firm smacks to the bottom of the cam DID THE TRICK!! Super cool!! Thanks for your help, those of you who posted about the smacking technique!!

Thu, 23 Jun 2011 02:29:28 +0000

This thread is making me ill. I had done this once before and thought it was just an accidental fix. I've sent the camera off to be repaired and I'm now waiting for the update. They said they already replaced something or other and I need to replace the wheel. DAMMIT. All I can hope for now is they haven't destroyed the ability to smack it to fix it. My stomach is turning.

Gary James
Wed, 06 Jul 2011 16:54:04 +0000

Firstly, you guys ROCK!!! I have a sony dcr-trv230e which takes Hi8 tapes. I have used this awesome forum before to help me with c3230 and c2100 error codes and all your previous advice has worked beautifully. I seek help once more. I am dealing with c3140 error and before you all yell, SMACK IT, I have! Which, I might add, has helped, a little. Currently my camera is doing this to me.... I open the back of the camera, the tape holding mechanism slowly comes up and pops out ready for a tape. If, at this point I close the tape holding mechanism it slowly takes itself back down into the camera and I can close the lid. Now, if i put a Hi8 tape in, it will push closed but it will NOT retreat back down into the camera. Instead, the thick metal disk inside the camera starts spinning (and wherrring), after about 10 seconds, the spinning stops and the sony ding, ding, ding starts and the error code is then displayed c3140. The tape is then automatically popped out. The error code disappears after the tape is taken out. It seems to be a problem with the loading of the tape because, as I mentioned earlier, when I close the tape holding mechanism without a tape inside, it simply goes about it's business and retracts back inside itself ready for me to close the lid. This camera is playing with me!! I really want to run my old Hi8's onto the computer but, at this stage, I dare not put any of them near this camera!! I trust in your advice. Thank you.

Sat, 23 Jul 2011 03:33:14 +0000

And, incidently, I have tried all the advice above, including the knob twisting bit, one of which was a little tight.

Sat, 23 Jul 2011 04:01:35 +0000

Add me as another one who tried and fixed it! Thank you for the postings. A whack about as hard as a hard clap on the bottom did the trick. I think I even paid for this situation once before when the camera was still relatively new.

Dave Dob rin
Fri, 12 Aug 2011 21:49:51 +0000

My Sony TRV 17 E, had the error C:31:40, found on this page which says to smack it's bottom, I get C:31:23 after smacking it. Then found another page, which says smack it too. Now it's working!!! Remind me of those black and white CRT TVs in the 70s..

Sat, 07 Jan 2012 00:41:47 +0300

Unbelievable !!!
Just 2 smacks in the bottom and my old DCR-HC90E is working again !!!
Thank you very much !!!

Daniel Susman
Sat, 07 Jan 2012 22:45:43 +0300

Not working for me but 'whack-a-cam' seems a good idea and is quite fun.

Tue, 24 Jan 2012 18:52:21 +0300

Started getting the 31:40 code about 7 years ago on a HandyCam 480X, so stopped using it for a long time. Just tried again so I could copy tape to DVD and after the first tape I got the damn code again. Tried whacking as suggested, but no luck. I'll let it (and me) cool down for a bit and try again. Hopefully it will work.

Sun, 08 Apr 2012 03:34:24 +0400

Took four or five time, but it is working. Unbelievable!!

Tue, 15 May 2012 00:32:14 +0400

I've found that storing the camera with a tape inside causes this problem to continue. whenever I store it with no tape inside, it never jams.

Fri, 18 May 2012 07:35:58 +0400

another satisfied whacker! it works. used some canned air for good measure. thanks internet.

Tue, 22 May 2012 00:46:48 +0400

Two firm smacks on each side and on the bottom worked for me too! Thank you all for your input. Stinkin tech support is no help at all - just want you to go out and buy another one.

cammy corder
Mon, 16 Jul 2012 01:51:10 +0400

hi! i have DCR-PC3E.. been smacking it like y'all said, but no luck.. and as a woman my palm is kinda painful now.. still getting that sound then that code error C:31:40.. i really want to use this cam again.. it's been a while since we last used it and we forgot the tape inside it.. so now what should i do??

Thu, 02 Aug 2012 13:56:51 +0400

whacking worked on my sony fx1, thanks for posting this.

Sat, 25 Aug 2012 00:04:37 +0400

An amazing solution to a problem that my HC42 has had for months! My grateful thanks to whoever on this forum first advocated it.

Thu, 15 Nov 2012 14:04:53 +0300

Thank you!
Finally got the time to transfer years of tapes to hard drive and I got the C:31:40 error, thought I had probably lost all the footage! But no, a smack on the bum and camcorder working fine again!!!

Wed, 28 Nov 2012 23:04:25 +0300

My problem C:41:40, solved by hitting the bottom part of my camera DCR-TRV7.
What a strange solution... xD

Wed, 19 Dec 2012 07:54:38 +0300

WHACK YOUR CAMERA THIS INSTANT! I'm very handy with intricate electronics, there is literally nothing I haven't fixed and many things I know nothing about from a technical standpoint. I've repaired the electronic components (I'm not talking a loose wire) DVD Players, VCR's, mini-DVD portable players, every electronic toy known to man (my business) LCD monitors, DLP TV's, PC's, Laptops and more. I visually saw a locking nut had fallen off the spindle and the rubber grommet was cracked and falling apart. It's not accessible without opening the entire body (don't assume you can just remove the door)
I found a guy who does these repairs like the broken ribbon cable (if your LCD goes blank) for $150 (Sony is triple) but this time I decided no way, I'm buying a digital as tape is dead. But...I have 25 tapes to transfer, my child's entire life is on them. I whacked it twice on the bottom of the unit and voila...fixed. PS Ignore the comments about knocking your unit "out of alignment", as I said, I'm an electronics whiz, no way that type of dull impact will knock it out. It's like saying if you hit a car in front of you at 10MPH will break your rear window. These are designed for some impact or every time you dropped your camera it would instantly break.

Tommy Daly
Wed, 19 Dec 2012 14:29:13 +0300

I had on my Sony TRV240E the error C:31:40 too.
After 3 hits with the flat hand on the bottom, the problem was solved.
It's cool.

Wed, 02 Jan 2013 18:49:41 +0300

Thanks for this help. After 5 or 6 hits in the botton of the camera my Sony DCR-HC42E works. The C:31 40 error was solved. :) Regards

Jos� Rodrigues
Thu, 07 Mar 2013 00:55:28 +0300

I can't friggin believe a good 6 hard smacks to the bottom was all it took smh it's crazy SONY trv315 error code c:31:40

Dee Brown
Fri, 08 Mar 2013 07:34:49 +0300

nono don't work dcr-hc24 don't work... neither with hair dryer

Sat, 01 Jun 2013 00:45:09 +0400

Smashing do not solved the problem
I realized it was the rotating head : I used a tweezer holing a mall piece of soft clean rubber to "force" it : it was actually bloked. Sliding gently I was able to make it rotate.
I re-inserted cassette and now it works again...

Thu, 01 Aug 2013 14:08:32 +0400

problema:C31 40
Es verdad con varias palmadas con la mano abierta en la parte donde va la cinta(con la puerta cerrada)SE SOLUCIONA EL PROBLEMA

jose gimeno
Sun, 29 Dec 2013 02:32:33 +0300

Amazing my DCR PC1000 after 5-10 hits with no tape inside start working again. Thanks a lot !!!!

Mon, 06 Jan 2014 11:24:24 +0300

It does work. I turned it on, took the tape out and smacked it firmly 5 or 6 times. Put the tape back in and it works.

Wed, 19 Mar 2014 19:44:39 +0300

Slap it gently in six axis positions and presto its working again. Be gentle.

Mon, 16 Jun 2014 02:44:37 +0400

Far out, I cant wait to try it. Hey Rudy from Belgium, how did it work on your wife?

Sun, 22 Jun 2014 06:48:22 +0400

Whacking my DCR-TRV340 Sony camcorder on the bottom with a flat hand twice (fairly firm smacks) fixed the C:31:40 error code and now the tapes load properly and completely into the tape mechanism. When I tried playing back some previous recordings however, it thought the tapes were Hi-8 instead of Digital-8 (which I new that they were). I tried inserting multiple tapes with Digital-8 recordings, but the LCD display kept reporting they were Hi-8. I reset the unit with a paper clip and the small recessed reset button, but I was still not able to play back the previous recordings. I then removed the battery and re-connected, but I was still not able to play back the previous recordings. I then switched the camcorder into record mode, recorded the wall for about 20 seconds, stopped the recording and tried to play the recording of the wall back and it corrected the problem and I was then able to playback all six of my previous recorded tapes!

Tue, 24 Jun 2014 07:49:01 +0400

Holy Cow - I am a IT Guy and have been dealing with this issue for a while - cleaning the heads, rollers, etc. even tried taking the roller out and reseating it still that damn error! Smacking it worked!

Fri, 27 Jun 2014 21:16:49 +0400

SONY DSR-TCR110E Fehlermeldung C31:40

Es funktioniert
Auf die Unterscheite schlagen und der Fehler ist behoben.
180 Euro Rep. gespart

Kaum zu glauben aber wahr

Sat, 18 Oct 2014 16:57:25 +0400


Sun, 25 Jan 2015 16:37:47 +0300

VX-2000. Same problem here too. Codes were different at first after attempting use the camera after few years of no use. Then, it stuck at the C:31:40. Few smacks here and there; tape loading side and the bottom. It did not help. Then, as someone tried to blow hot air. Pronto... Before smacking it silly, try to blow hot air with a hair drier but be gentle. Don't melt things inside. Keep moving the nozzle, don;t get too close, be patient. My guess is, lubricants dry out over time and get sticky. Smacking might get it loose by breaking the mating surface apart but doesn't make the lubricant nonstick. As a preventative measure, I will run it fe minutes once a month till the mechanism gets hot. Thanks to all who contributed.

Sat, 31 Jan 2015 16:49:29 +0300

Smacked my Sony DCR-TRV 120 several times on the bottom, tape side and now it works. The camera had been unusable for several years, but now can be used to transfer video to dvd. Thanks for the advice.

Thu, 16 Apr 2015 05:20:16 +0400

Yesssss! Ich habs auch gemacht und viele verloren geglaubte videos sind gerettet!

I did it too... and many videos I thoght I had lost are saved.
Thanks to the creative pioneer...

Error: C:31:40

G�nther W
Sat, 27 Jun 2015 17:40:27 +0400

OMG it totally did. Spent a week and a half trying to get the cassette carriage to close when it had a tape in it. Tried multiple tapes, cleaned the mechanism and went as far as to do a factory reset. Nothing worked. Today I found this thread and smacking the bottom totally worked. I'm shocked - would not have bet $ on it working. Thanks!

Sun, 10 Jan 2016 00:18:54 +0300

Sony DSR-PD170P, same error msg "C:31:40". Then I hit it with a mini wrench its rubber grip from the bottom, but later there was nothing changing.
I realized as there's the casette's lid open, I had to push the metal mechanism little bit more inside from the deeper corner at lens side.
Great it worked again! Thanks guys!!!

Attached Image:


Abdullah ER
Sat, 06 Feb 2016 06:17:27 +0300

I just bought a Sony handycam TRV608 from EBay. It was affordable and seemed to be from a reputable electronics repair guy so I felt comfortable purchasing it. Like everyone else I still have some hi8 video cassettes from about 15 years ago when I was in high school that I want to see if there's anything worth transferring to digital. I never understood how to do that at that age so the tapes have just been floating with me as an adult after some other kid jacked up the original camcorder I had.

Anyway, I received the refurbished TRV608 in the mail yesterday and to my dismay I was immediately welcomed to a C:31:40 error message. Thank you Sony for having such incredible detail in your instruction manual for troubleshooting this issue (where's the sarc font button?). I finally searched the error code online after I tried removing battery and tape from the camcorder maybe a couple dozen times. I had to read maybe another couple dozen threads posts on this thread of everyone here spanking the bottom of their camcorders before I was comfortable doing it too. For all I knew “” was developed as a practical joke to unexperienced videographers like myself.

So I spanked it several times without any improvements. I couldn't figure out what was wrong, and I was getting more sad and disgruntled by the minute. I turned the camcorder up over my head to look inside the tape deck and decide to shake it a bit. Soon enough a black, cylindrical, rubber piece fell onto my face. I didn't know what it was. I left it out and put the tape back in. This time I received a C:31:22 error. I still didn't understand what was wrong, and eventually I took to YouTube. The first video I found for that error code was a pothead talking about that rubber cylinder. I guess it gets dislodged from time to time and needs replaced.

I can't explain which piece it is here, but there's a silver pole that the rubber cylinder slides onto in order for the camcorder to function properly. I slipped it on, and the camcorder works just fine now. My assumption is that it fell out of place during shipping which is why I received the C:31:40 error code initially. I'm not sure that the spanking did much other than fully dislodging the rubber cylinder. Luckily it fell into my lap though, because without that piece my camcorder would never work and I wouldn't have ever known why. Hope this helps out someone else.

TL/DR: Just read it. It's not that long.

Jeff Barnett
Tue, 10 Jul 2018 04:34:44 -0700

Sony Handycam DCR-TRV740
Issue: Tape would not load, error C31:40
Rubber cylinder and spinning wheels seemed to be in place and moving fine.
Tried Sony's solution, soft and hard reset, different tape, no prevail.
Turned the camera with the bottom up, no tape, no battery.
While holding the camera in my right hand, I smacked six firm doubles on the bottom: PAM-PAM, PAM-PAM..., using my three middle finger, left hand.
Now tape is loading, no error.
Will check the internals again, not very comfortable smacking again.

Mihai P
Tue, 11 Sep 2018 10:09:04 -0700

Error code C31:40 for Sony DCR-TRV17 - whacking didn't work, but thanks to nitopi from Aug 1 2013, I gave the large head near the bottom of the compartment a push and voila! It worked! Happy girl tonight thanks to this discussion!

Laurie B
Sat, 10 Nov 2018 21:13:09 -0800

Eric wrote years before:"Hi had the same problem with a Sony Hi8 from 1998 (c:31:40). The camera was useless.
Ar several forums I found out how to solve it. Hit your camera several times with a flat hand (bottom, tape side). Its strange but my problem was solved. On internet I found maybe 10 or 15 other people who did the same. For all of them this worked fine!"
My old SONY DCR TRV330 had the same problem when I decided to activate it after years. I took out the tape and closed it and smacked the bottom 15 times. It WORKS AGAIN!!!
Thanks a lot!

Sat, 26 Jan 2019 06:58:48 -0800

Ditto... TRV 330 - not used for 3 years.. 31:40 error... a few mild smacks on the bottom for the tape side... eject tape, reinsert.. working now. Not so sure this is the best solution, but sure is quick easy and best fo all free...(unless smacking eventually induces more expensive repairs.. which would justify throwing it out entirely)

Jim H
Wed, 15 Jan 2020 07:59:04 -0800

Many many years after the original post... It's now 2020 and I bought a Sony Hi8 from a yard sale. It did not work at all at first and then got the code. I smacked it and it sort of worked, so I waited a day and smacked it again.... What do you know... It worked. Add me to the list of amazed people.

Mike F Poole
Mon, 21 Sep 2020 18:23:03 -0700

My mouth dropped open when hitting the camera worked for me! I got the c 31 : 40 error message. I hit it once and it didn't work. Tried probably 3 or 4 times, one of them I gently but somewhat more forcefully than before hit the camera on each side. IT WORKED!

Tue, 18 May 2021 11:56:03 -0700

I can't believe it. I just can't. It actually worked. I smacked it lightly about 20 times holding it upside down and hitting the bottom. The cassette started spinning and now it plays! Like something was stuck and now is free. Thank you!

Sun, 16 Jan 2022 14:04:29 -0800

Worked for me as well. C31:40 error. Was copying old tapes to hard drives. After about 20 hours of footage got the error. Nothing worked. So based on the positive outcomes noted, I tried hitting the base of the camera (closed and turned off without a cassette loaded) 10 times with an open palm, medium force. It worked, back taping. Perhaps not a long term solution, but doesnt matter, just trying to get my content to a hard drive.

Sun, 12 Feb 2023 14:02:46 -0800

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.

Add Comment

Spam Control | * indicates required field
Your Name: *
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 7 + 9?
Click button only once, please!


TrackBack only accepted from WebSite-X Suite web sites. Do not submit TrackBacks from other sites.

Send Ping | TrackBack URL | Spam Control

No TrackBacks yet. TrackBack can be used to link this thread to your weblog, or link your weblog to this thread. In addition, TrackBack can be used as a form of remote commenting. Rather than posting the comment directly on this thread, you can posts it on your own weblog. Then have your weblog sends a TrackBack ping to the TrackBack URL, so that your post would show up here.

Messages, files, and images copyright by respective owners.