Camera Hacker

: :

Add Comment | Related Links | TrackBack
Related Content

c31:30 error code

I have a sony trv-11 that keeps locking
up and displaying c31:30. Anyone have a
solution for this?

Sun, 12 Feb 2006 13:05:39 -0800

I had the same problem on my TRV320. My camera would open but if I inserted a tape it would error. I was about to put it in for repair when I read the C31:23 thread. I tried the "give it a bang" theory and it worked! Procedure open palm of hand and give it a good knock, after each knock rotate it about 90 degrees. took a few attempts, see how long it goes for.

Tue, 28 Feb 2006 03:29:57 -0800

Greg's solution worked for me. I've knocked each side of the camera with open palm a couple of times, then removed and re-inserted the tape... It just works :)

Thu, 05 Oct 2006 02:37:43 -0700

I knocked the sides too and it worked - but why and how? whats the cause. There is usually a whirring motor sound when this happens.

Fri, 01 Dec 2006 00:23:22 -0800

increible pero cierto...� le di un golpe en seco con la palma de la mano en la parte de abajo del lente y el error desaparece.....

Sat, 22 Mar 2008 20:34:32 +0000

Hey, I'd got a Sony cam with this error but tape door opened and won't close (with or without tape).... I slaped the cam, rotated 90 degrees... and door closed.


Oye, ten�a una c�mara Sony con este error pero ten�a la tapa de la cinta abierta y no se cerraba (ni con cinta ni sin cinta).... le di golpe, la rot� 90 grados... y la tapa se cerr�.


Mon, 01 Sep 2008 21:21:20 +0000

Error Code 31:30 Sony TRV 730E
- Thanks for the "give it a bang" theory! It worked!

Tue, 09 Sep 2008 06:16:54 +0000

Okay when I first saw this theory i was VERY skeptical. I especially didn't want to try it because I'm in the middle of editing a wedding video. But i thought what do i got to lose since the tape is gunna be stuck anyways.. and let me tell you.. IT WORKS.. I was surprised but it works!!! thank you very very much!

Thu, 11 Sep 2008 18:50:46 +0000

Ref 31:30. I was about to use a hammer on my Sony TRV-308 when I came across this page. I was always told to not bang your equipment around but I slapped it around a couple of times and the tape ejected. You guys saved me some money. Thank you.

C Ness
Thu, 06 Nov 2008 03:04:14 +0000

UNBELIEVABLE! I have a Sony DCR-TRV6E. I also had the C31:30 error. Tried several things. Nothing working. After "Googling" I found this site. I was very skeptic about the "give it a bang" solution, especially because I'm very careful with my camera. But I gave it a try and it worked!!!
Greg: many, many thanx for your solution. If you where a girl, I would give you a kiss ;-)

Sun, 09 Nov 2008 07:24:16 +0000

Wow! Holy guacamole! It worked!!! I once had this problem before with my now nearly antique TRV-20 (the camcorder wouldn't close). I spent over a $100 on fixing it. By accident, a year later, I pop in the same tape that caused the problem. This time I managed to get the camera to close by removing all power (power cord and battery). Then I opened the palm of my hand as suggested here, hit the bottom of the camera a couple of times and tried to eject the tape again. First it seemed to struggle a bit then POP! The tape ejected. Something is weird with that tape since it definitely seems to be the only one of my tapes that causes the C:31:30 error code. Wow, who would ever have thunk that ignoring the DON"T BANG THE CAMERA rule was the actual solution...

FYI, the bang with an open palm does not have to be that hard, just enough to cause a few sudden jolts...

Mon, 02 Feb 2009 20:28:45 +0000

You do not realise how suprised I was that this worked. As an electronics engineer it does not make sense, I was about to ditch the camera for a new one and thought I would google the error code. The code did not go until I removed the tape and reinserted, so far so good. many thanks.

Sun, 15 Mar 2009 08:08:21 +0000

C31 Error :
I was very surprise when I came across this site. It Reminded me of the old Quantum IDE Harddrive. The head stop spinning and all you had to do is just slapp the sides and it would start spinning again. Bravo thank you..

Fri, 17 Apr 2009 00:03:10 +0000

OK. I tried it and thus far it works, but that's only been about half an hour. Does anyone know WHY this works? Do we have a bad (cold solder) problem in the camera and the jarring temporarily shocks the circuit so that the little voltage required is able to pass through. We know, however, that such things will only last a little while and then the break will become more and more intermittent and finally fail once and for all. OR is the problem dust/debris in the works and this supposedly jarrs it loose. Or a sticky senser or trip lever? Any ideas?

Mon, 04 May 2009 16:33:45 +0000

Insane, hitting it worked. Had this camera lying around for 2 years and finally got it to work thanks to this very technical approach!

Jonathan Brun
Thu, 23 Jul 2009 22:18:02 +0000

Amazing it really does work. Many thanks to the original "tech buster." Credit where credit due!

Wed, 21 Apr 2010 16:59:56 +0000

This is great. It worked. I would have thrown my perfectly working cam corder to trash. Thanks very much. Sony should put this in their web site. Also. I have DCR-TRV 460 Sony Camcorder.

Sat, 08 May 2010 18:00:48 +0000

Sony DCR-TRV6E. I also had the C31:30 error. One bang and ... problem solved! Thanks!

Sat, 05 Feb 2011 12:31:19 +0000

Once opened by the above technique ,a minute amount of grease appled with the point of a cocktail stick to every place where the casette holding frame slides ie pins that move within the confines of a slot,pivot points, and raised surfaces that slide over one another ,then press the frame in as if loading the cassette but not qute to closure so it springs back out,when released do this a few times This will probably prevent this problem occuring again for a long time , but don't get any grease anywhere near the tape path( this worked for me, but you do this at your own risk !)

Mon, 30 May 2011 23:09:23 +0000

I have a trv 20e pal version and the tape was jammed inside the cassette compartment and it gave the error code c 31 30. I'm going out filming tomorrow and I was desperate. I googled the error code and came across this site. I've never misbehaved my cameras and this wasn't typical thing to do, the blast from the side with my fist. I was desperate and tried with my open hand and it didn't work. But after I hitted it from the side and shaked it as it was a coctail mixer it started working. The cassette came out nicely and the error code is gone. Now I'm just hoping it will work tomorrow on the set...

Thank you for the brutal instructions.

PS: I had to hit the camera "pretty" hard on the cassette compartment side.

Fri, 08 Jul 2011 19:39:07 +0000

Well, here's a time Google really came through. This is the first time my TRV-11 quit working. I mean, it's been a real work horse used for my grandson's football programs. I was getting ready for game tomorrow and wanted to start a new tape. The tape would not come out and a C31:30 code was blinking. I googled the error code and after reading this site, gave the camera a swift slap on the side it it opened like it always have. Thanks for all the post for this remedy. It saved me from having to buy a new camera at 10:00 at night.

Sat, 03 Sep 2011 01:59:43 +0000

i have a trv 340, ive been having all soughts of tape mechanism and loading dramas in the last couple of weeks but now it finally seems to be loading again, had it playing with a couple of tapes but with blue screen or grey bars, then it stoped playing tapes again with a 31:30 every time i press play, i can just turn it on and off and it ejects fine but wont play.

Fri, 13 Jul 2012 01:28:57 +0400

Still works. Unreal!
Sony Hi-8 TRV530.
Thank you very much.
Scott A.

Scott A.
Mon, 31 Dec 2012 06:38:19 +0300

Here it is March of 2013. My Digital 8 Camera tape was stuck. And sure enought I banged it and bit and it opened. Freakin' amazing. Thanks all for your posts. What a trip.

Sat, 09 Mar 2013 09:24:48 +0300

I just bought a replacement camcorder on ebay to replace my circa 2000 TRV-11 that my ex stole in the divorce. I want to finally get all the home movies transferred to Hard Disk. But when it arrived, it kept sticking during tape load and giving me the C:31:30 error. I fiddled with it for 4 hours tonight and couldnt get it to work for more than a few seconds. Finally I google the problem, find this website, try smacking my camcorder up. Wow, I can't believe it worked like black magic! Thanks everyone.

Tim Shepard
Thu, 11 Apr 2013 09:51:11 +0400

Yep this totally worked on my TRV-530 that I bought new in 2001. I only use this as a tape deck for Final Cut Pro so it doesn't get much use. Glad I found this site

Russ Arteaga
Tue, 20 Aug 2013 22:55:38 +0400

10 out of 10 - This really does work!
Blew my mind...

Tue, 28 Jul 2015 14:51:21 +0400

The bang it rule works also for the Sony dcr-pc1000e

Fri, 27 Oct 2017 15:16:53 -0700

omg it is incredible it totally work, thank you!

Mon, 15 Apr 2019 20:31:59 -0700

Got on ebay to look for used one......saw this thread......and guess what.
IT WORKS after I popped it in the side!

Sun, 05 May 2019 21:29:23 -0700

Holy crap it worked. Despite reading all the good reviews of this method, I still doubted it. But I am back to playing my videos (and transferring them to my PC as I do!)

Thank you, internet!

Wed, 10 Jul 2019 18:44:53 -0700

Davvero mitico.. funziona il botto. Grazie grazie

Sun, 29 Dec 2019 15:07:05 -0800

That is unbelievable!!! It also worked for me. My Cam is a Sony DCR-TRV330e.
Thank you very much!

Wed, 05 Feb 2020 04:22:31 -0800

Crazy, worked on a 20+ year old camera. Epic!

Sat, 24 Oct 2020 07:51:51 -0700

T H A N K Y O U V E R Y M U C H !!!
I was really skeptical but I thought "what if it works?"
and it worked also for me with a DCR-TRV20E with more than 20 years.

Wed, 06 Jan 2021 07:55:52 -0800

It's 2021, I have a cranky Sony here that would close on the tape then refuse to feed it in, giving the same error ocde. It would eventually release the tape again though, so thought this is not going to work. Closed the tape door, powered it off and gave it a not very hard slap on all sides... and bloody hell it works now. Stupid, yet amazing. Thanks for this weird but useful trick.

Thu, 21 Oct 2021 17:18:08 -0700

I just found an old Sony DCR-PC109 with a tape inside and a box of other tapes, all of which I would love to digitize. But, I can't get the tape to eject. I tried the banging approach, but no go.

Any other ideas?

I open the door to eject the tape. It whirs for a while. And then nothing except for an error C:31:30.


Thu, 20 Jul 2023 12:23:36 -0700

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.

Add Comment

Spam Control | * indicates required field
Your Name: *
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 0 + 7?
Click button only once, please!


TrackBack only accepted from WebSite-X Suite web sites. Do not submit TrackBacks from other sites.

Send Ping | TrackBack URL | Spam Control

No TrackBacks yet. TrackBack can be used to link this thread to your weblog, or link your weblog to this thread. In addition, TrackBack can be used as a form of remote commenting. Rather than posting the comment directly on this thread, you can posts it on your own weblog. Then have your weblog sends a TrackBack ping to the TrackBack URL, so that your post would show up here.

Messages, files, and images copyright by respective owners.