Camera Hacker

: :

Add Comment | Related Links | TrackBack
Related Content

Error Code C:31:xx

Regarding the Error Code C:31:22.

I disconnect power and the error code goes away but repeatedly returns after a short period of operation of my DCR TRV-250.

I have tried different tapes, AC and DC power supplies. We just returned from a humid environment and am "acclimating" my camcorder for an hour or so.

I haven't cleaned the video heads yet, either.

Any other ideas?

Scott
Sun May 29 23:40:07 PDT 2005

i use my camcorder in a foggy weather and gave an error code c3142. please give any suggestions on how to rectfy it.

william

william
Mon, 8 Aug 2005 07:47:23 -0700

Try refering to this thread:
Error Code C:31:23?

Chieh Cheng
Mon, 8 Aug 2005 10:29:50 -0700

I have a SONY DSR-PD170P camera. I contacted SONY and they told me that C31 is a Tape Loading Error. They suggested removing the camera battery. Then re-connect and then re-set the camera back to factory conditions. If it persisits it may require attention.

TREFLYN JONES
Tue, 18 Oct 2005 08:33:44 -0700

After trying everything suggested, my DCR-PC5 still gives the C31:22 sometimes. I didn't try smacking it.

Lucase
Mon, 27 Feb 2006 11:28:17 -0800

Greetings, I get the 31:23 regardless. I have disconnected used new tapes waited days between attempts and reset the device repeatedly. How can I find a sony service center or can I use anyone local like at Fry's due to the lack of severity of the code?

Bruce
Tue, 28 Feb 2006 20:57:51 -0800

i am using Sony DVCAM DSR45P. today i found Error C3123 disply. i resrstarted the DVCAM , reload the tape , but still the same problem remain. what should i do?

sohail
Sat, 10 Jun 2006 04:23:56 -0700

I had the same problem with my DCR-TRV 250, I was getting the error c:33:23 then I reset my camera now it is in working state.

Thanks

Satwinder
Sun, 02 Jul 2006 13:35:16 -0700

My dcr-trv740 has been consistently displaying a c:31:22 and c:31:23 the past few days and nothing, even gentle smacking, is of any help. (The error showed up during recording in a cloud of dense sparkler smoke on the very humid 4th celebration.) Occasionally i can FF or rewind a tape, but not record. The errors indicate either a take-up or source reel problem ("sticktion"), so I cleaned the tape path and heads with a chamois/head cleaner solution. No luck. I then noticed with the deck open that the S-table assembly (rear one) would not rotate freely, while the T-table assembly does. Just a bit of force and it would "break free" and spin freely until closing and re-opening the compartment. Now, is this normal? Or is this the cause of the tension problem and subsequent error code? I will next disassemble the 740 to check the teeth on the gears, and to clean and apply fresh oil and lithium grease.

greg
Fri, 07 Jul 2006 07:20:57 -0700

I have a Sony CCD-TRV118 digital camcorder that has the error code C:31:22 when I put a tape in and try to record. It says standby when I reset it or remove the battery for a minute, but once I start recording it has the error again. It only shows the error when the tape is in and I've tried different tapes with the same results. How do I fix the error?

Chris Tarren
Wed, 04 Oct 2006 17:37:25 -0700

I wouldn't have believed it if I hadn't tried it myself, but if you give it a whack with an open palm on the side, it might just work. If you don't beieve it, just take a look at this thread. Error Code C:31:23?

runningshoes
Wed, 08 Nov 2006 11:50:19 -0800

I have Sony VX2100E, DCR-TR/145E and DCR-TRV250 camcorder and same problem... every time C:31:22

Nuri KETHUDAN
Mon, 01 Jan 2007 10:07:10 -0800

it's solved just see the pics
I have the Error c:32:23 and C:31:22

I reviewed almost all the comments tall about smacking the camera it's sound a mechanical problem, this why I try to check the Mechanics as u can see In Pictures attached the back Rubber wheel is not in the proper place and the white plastic lock is not there when I flipped the camera upside down it's come out (the white plastic lock) then I place it BACK so the error is gone that grate no more C:32:23

I wish this will help others

Regards

Ahmed Jasim
Iraq

Attached Image:

handy.JPG

Ahmed Jasim
Tue, 09 Jan 2007 12:33:59 -0800

HI ahmed.

Im getting error C:31:22 and when i opened the camera, the little "white plastic lock" you mentioned fell out. It is not clear from your post where it needs to go back. Can you give a little more advice for this techno-noob. Thanks!

Hiya
Mon, 12 Feb 2007 10:36:20 -0800

I called a camera repair shop and they gave me Sony's parts number (800) 488-7669. When I finally got through I had a C/S representative that was unable to determine what "white plastic lock" I was referring to (mine is gone). I don't have a home fax so she was unable to get me the specs to determine the part number. Does anyone know what part number that would be in the DCR-TRV17? I want to sell my camera.

By the way I bought the Panasonic GS300 last summer and I love it! No issues

Ryan
Sat, 17 Feb 2007 12:04:15 -0800

Ahmed, you are awesome!!!!!

I had been looking throughout the internet to try to find a picture of the stupid error, and thank god you posted one. I had lost the little white plastic so I just cut a piece of the inner tube of a ball point pin and inserted it. I did what you said to do and the flippin thing worked!!!!! My husband and I are going to take our only 2 year old little boy to Disneyworld and we really needed to have our camera for this trip.

Thanks Again, one happy mommy:)

Sofia
Mon, 19 Mar 2007 12:28:41 -0800

I had suffered from C31:23 problem for 2 years with my DCR TRV740 and pay more than 200$ in a certified service center no body was able to give help. Finally, a couple of months ago I decided to disassemble my camcorder, I found a small rubber roller stick to the video head. Succefuly , I allocated the right axis where this rubber roller should fit. It could be seen when the cartridge cover is opened (without disassembling the unit). Actually, it is a moveable axis (you can push it to slide with your finger). The role of the roller is to pull the tape and stick it to the video head.
Joyfully, the camcorder worked but the roller could slip out of the axis without a Proper Lock to fix it on its place. This is the defect of SONY design they manufactured a small tiny ring to hold the rubber roller on the axis, after 1-2 years of operation this tiny ring would break which cause the error C31:23, what I did is I fetch in my box of small hardware part for a small plastic ring with a one millimeter cylinder in its middle to fit around the axis and the I use "Patex" glue to fix it on the top of the axis to prevent the roller of moving out.
It worked

this is the first time I came back to this site after my first enounters of the problem, I am glade that Mr. Ahmad Jasim came to the right analysis and solution.
Lebanon
Jamil Nakhal

Jamil Nakhal
Tue, 27 Mar 2007 00:36:33 -0800

Hi again (long time )

Am really happy to see my self helped to make all this number of people feel happy to fix their hand cam thanks for all nice comments

Please find the picture below to clear any ambiguity regarding the roller wheel placement

Regards

Attached Image:

hanycam Error.jpg

Ahmed Jasim
Wed, 06 Jun 2007 10:15:41 -0700

I'm getting the same error messages. I also noticed that the black rubber roller was off of its spindle. I have't secired it with a plastic lock, yet. However, I'm testing it with the camera on its side, so that the roller will not come off. I kow I need to secure it.

I'm also resetting the white tab from the lock position on the spindle that "drives" the tape wheel that collects or winds up the tape.

I'm having a problem with the tape itself coming out into the camera. It seems to be wrapping around the rubber roller. Is it possible that the roller is moving up and down too much, since it is not secured? Any other ideas? ideas?

rs
Sun, 10 Jun 2007 13:09:03 -0700

I wish I had spent sometime searching on this site. I had the same problem in May 07, but it took disassembling the camera to resovle the dam black rubber wheel was missplaced and laying out of place at the bottom of the tap case.

Meron
Sat, 16 Jun 2007 08:29:18 -0700

I the C:31:22 error with both my FX-1 and Z1-U with only certain tapes. Others play fine, and this happens with multiple brands of tapes (sony included). It generally happens towards the end of the tape and usually when i try to fast forward. There is no "white piece" that fell out and it looks like everything is OK inside. I'm getting the runaround with sony...someone help!!!

jeffrey
Wed, 20 Jun 2007 11:38:08 -0700

Hai, if the error C:31:22 and sometimes 23 but i'm the white thing lost, can any body help me please
mail to: [email protected]

Marvin
Tue, 17 Jul 2007 13:27:14 -0500

Dear Ahmed Jasim,

Many thanks for posting the pictures.

I have a Sony DCR-TRV340 and was getting message C:31:23. The rubber wheel had fallen inside the cam. I placed it back to its position and my cam is working fine. However I could not find the white plastic lock. I may have to contact sony for this.

Thanks again for your excellent posting!!

Regards,
Sudhir

sudhir
Mon, 30 Jul 2007 02:25:22 +0000

Dear Sudhir

I've concluded that sony dealers don't have the white lock in their stocks as a spare part. you have to make one by yourself.
The diameter of the spindle axes is exactly one millimeter. you should find a copper tube of 1 millimeter inner dimmension (from a hardware store) cut a 3-4 mm of it (usually it comes in 1 meter long) use a mini disc drill to cut it, do not use a cutter because it will deform the tube. if you find the made lock loose and do not grip around the spindle then you should enter a tailoring needle in the made lock then poor a little bit of "patex" cement on its extreme and pull it out again. now the patex glue should fill the made lock. push the lock into its supposed position. use it the next day.

N.B: you don't have to disassemble the camera, just disassemble the door plastic cover

Regards,
Jamil Nakhal

Jamil Nakhal
Wed, 22 Aug 2007 11:26:40 +0000

me aparece el error c 32 en una sony 170 dvcam ,busco en el manual y me aparece error no descrito anteriormente.muchas gracias si pueden mandarme alguna rspuesta

marcelo
Wed, 10 Oct 2007 16:36:05 +0000

ok I have a Sony DCR-TRV18 MINI DV CAMCORDER it had the error codeC31:23 I found out why here the rubber pinch roller had indeed fallen of the shaft and was in the back of the cassette tray lucky it stayed in the camera with jewelers needle nose I care fully retrieved it and now for the white pin it was gone but being a prolific tinkerer i soon found a relacement I used the ink tube from a bic pen with a pair of side cutters again small I clipped a suitable piece of ink tube sans the ink I replaced the roller on the capstan and useing the needle nose pressed the piece of ink tube on the capstan to hold the roller nice tight fit the roller spins freely with the side cutter I clipped the excess ink tube and bingo the camera now works great once again MY THANKS TO ALL HERE WHO put thier knowledge out there for us to read

JD
Sat, 13 Oct 2007 18:38:59 +0000

Thanks to Ahmed Jasim and his knowledge! And to all of you who contibuted with your knowledge!!! I managed to fix my DCR-TRV17E. The white plastic cap in my case just got loose. I managed to put it back in its place and all works again (at the moment!). Again, thanks to all!!!

Javier Tarrio
Madrid, Spain

tariro
Fri, 09 Nov 2007 16:29:58 +0000

I'd also like to thank Ahmed- I was just about to give up hope and take the camcorder in for a very expensive repair when I found his post. In my case the rubber pinch roller had come completely off the shaft & had lodged in the bottom of the tape compartment. I turned the camera upside down & sure enough a small white plastic tube-retainer fell out. Using the photos I was able to determine where it (and the roller) came from & now the camera works like new again. I plan to periodically push the retainer in to ensure that it does not work its way off the shaft again. Thanks for taking the time to post the photos and explanation- it saved me some serious money.

Dan V.
Tue, 13 Nov 2007 03:55:31 +0000

I have been having all sorts of C31xx errors for quitea while. It worked sometimes by smashing it with the palm of the hand. Then it started not to work again. Reading this forum I had a look inside the gearing in the cassette slot, but
everything seemed all right. Then I noticed the housing of the cassette was way loose to the bodu of the camera. I just pressed it close to the camera so to make it better adhere to the frame, and everything went fine. Maybe some loose screw inside. I'm not the terms I'm using here are correct tough.

luciano
Sat, 17 Nov 2007 13:24:15 +0000

Dear Ahmed Jasim,

You are amazing! Thanks ever so much for posting this article and the pictures. In my case I was lucky that both the wheel and the white plastic lock fell out. I noticed that the plastick lock was cracked lengthwise so before putting it all back together I glued this. No more C31xx errors.

Thank you so much!

Armin

Armin
Fri, 07 Dec 2007 20:43:58 +0000

Ahmed,
you are a hero! This damned thing has been hapening for ages. I've got a Sony DCR-HC30E...I think thats pretty old now? But sorted now. My Sony phone, and PSP always take loads of bashing around, but my camcorder never seemed to live up to the indestructability of my other Sony goods. You have saved at least a dozen people £200 or so! If I were you...I'd start charing...:P
Jamie

Jamie Gollings
Sat, 22 Dec 2007 13:16:08 +0000

The pinch roller is the problem. I removed the white plastic piece which was cracked and replaced it with a similar sized piece cut from the end of an ink refill and voila the camera works like new. Thanks for the pictures.

Blade
Mon, 24 Dec 2007 21:37:27 +0000

Hi Ahmed
Thanks for your advise and pictures ( pictures were amazing ), thanks to you I repair my Sony TRV240 camcorder for free.
The black rubber wheel was of the spindle and was laying inside the camcorder. I did not find white cap but I will try to make of something .
Thank again

Marek

Marek Felinski
Thu, 27 Dec 2007 21:23:14 +0000

Ahmed: Thank you! My camera has worked flawlessly for all these years and then on Christmas morning - 31:23! I couldn't tell the kids to wait until I figured out the problem, so we missed taping this year's festivities. BUT, instead of asking my husband to fix or replace it, I found your post (and excellent pictures and diagram) and fixed it myself! I found the black roller piece after a couple of slight whacks to the side of the camera. No white piece, though, so another thanks to JD and the others who suggest the ink tube solution to the missing white piece.

Wishing you all happy recording in 2008!!

Dawn
Sat, 29 Dec 2007 18:00:56 +0000

great thread!
i have C:31:23 problem with my DCR-PC350E right now. and almost every time i eject the cassette, the tape is outside of the plastic cassette box.
the pinch roller looks normal.
anyone knows what to do with that?

yanouche
Mon, 31 Dec 2007 00:39:18 +0000

I got my camcorder working again by using heat shrink tubing, but I couldn't have figured it out with all your help. The bic pen tubing was too loose for my TRV240. I found some heat shrink tubing that was also a little bit too loose, so I shrunk one end and discovered it was now too tight. I clipped off the end that was too loose and the end that was too tight to make it funnel shaped. I put the roller back on and pushed the loose end of the heat shrink tubing over the capstan until the tight end was perfectly snug.

David
Tue, 01 Jan 2008 04:32:11 +0000

Excellent source for fixing my camcorder. Ahmed your diagnosis was right on! Thanks from the USA! Sony wanted $211 to fix it.

Thanks again!

Tom
Wed, 02 Jan 2008 01:55:13 +0000

Much thanks to Ahmed and all the other people here who graciously took their time to help others with no reward. If life worked as well as this website has in helping people, world hunger would be a thing of the past!

Herbert Fellows
Wed, 02 Jan 2008 17:48:08 +0000

Thanks much to Ahmed for the fix to my TRV 740 that i already paid $50 to a repair shop that told me my unit could not be fixed. From your picture i could see the roller was missing and on my close inspection i found it jamed down the botom of the case. Still having trouble fabricating a new retainer. The Bic pen ink cart does not fit tight enough on the capstan axis. THANKS AGAIN AHMED nice job on the pictures!!

Kurte
Fri, 04 Jan 2008 03:53:00 +0000

FYI, according to Sony DAPC, their parts department, the official part name and number is: ROLLER AND LOCK ARM ASSEMBLY, PART NUMBER 39529341.

NOW, YA READY? $25.27, PLUS TAX AND SHIPPING! When I said i thought that was a bit high for a 1/3rd of an inch piece of plastic, the clerk informed me, with much indignation in his voice, that the 1/2 inch rubber roller was also included! I feel much better getting two 10 cent parts for $25 rather than just one!

In business, this is referred to as 'I am the only one who has it, how badly do you want it?'

BOYCOTT SONY!

herb fellows
Fri, 11 Jan 2008 16:46:17 +0000

Thanks for the pn, but it is not correct. It is supposed to be 9 digits, but just tell them roller and lock arm assembly, and they will find it. Thanks everyone.

Fernando
Mon, 21 Jan 2008 23:51:46 +0000

Dont mean to be a "noob", but can someone please tell me how in the world are you guys taking your cams apart to fix them. I have the same rubber/pin problem. I tried to stick my hand inside my trv-250 and the black piece that holds the pins popped out[this was before i read the messages here]. It appears to have come out cleanly without anything being broken, but I dont know where to start on dismantling this thing so that I can place the pins back inside. I am so disgusted with SONY I dont know what to do. I just got the camera back due to the suit that was filed against them concerning the CCD screen issues. Now this...

Please help, my friends!!!!!

SONY's A PHONY
Tue, 29 Jan 2008 12:49:05 +0000

Have the same problem with a DCR-TRV17, the white thingy seems not able to come down to be completely flush with the pinch roller,I pressed down with a lot of forceand still the white piece can be seen, is that normal? on amhed's photo's. the white plastic piece seems to go all the way in.

thanks

Keko
Fri, 01 Feb 2008 08:25:24 +0000

Found it in the bottom of the camera!!! Thank you so much!!!!

Jessica
Thu, 07 Feb 2008 02:21:42 +0000

If this site does not exist, I would have surely gone mad. Trying to video my 10 yrs old daughter and ageing family dog in the first sunshine of the new year, i got this error code C:31:21
Have sent email to Sony, but being a Saturday, and not at all wanting to spend money on my videoing hobby at the moment, I went on the net and found THIS SITE. Without the pictures and the posts found here, I would have spent loads of money (too much anyway for a single mum) on a new equipment.
Thanks guys, everybody, who took the time here. Though for me smacking did not help, only terrified my daughter who didn't know why Mum was going crazily against the machine.

Thanks all and if anybody ever needs help please write to me freely!!!!!!!!!!!!!!!

Katalin WITH LOADS OF THANKS, and believe anyone finding this site, what is written here WILL HELP!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Best wish from Hungary, but I am not sure if I will again buy Sony articles.

Kata
Sat, 09 Feb 2008 20:27:01 +0000

Hello All
Great feedback here, and those pictures really enlightened me. Thanks Ahmed Jasim. The problem is, I did not find the parts, how can I buy those? Any similar parts around? Please help
Meno

giovetti
Sat, 09 Feb 2008 23:42:12 +0000

I own a sony mini-DV tape deck model GV-D1000 and I have the dreaded C:3123 code. This f**king code made me lose a Craigslist sale on this very deck! Well, thanks to this forum and to Ahmed Jasim's pen ink tube DIY fix, I was able to alleviate this freekin error code. In fact, I was so intrigued by this fix I'm creating how-to web page about it with some nice sharp macro shots as my contribution for this fix! I will post up the link when the page is ready.

Jason Katman
Sun, 17 Feb 2008 07:47:00 +0000

here's a link to my how-to article on Ahmed's Pen Tube fix:
Sony Error Code C:31:23 DIY Fix

Jason Katman
Sun, 17 Feb 2008 10:45:45 +0000

OK GUYS, I HAVE HAD THIS C:31-23 ERROR CODE AS WELL, TRIED THE "WHACK" THEORY, DIDN'T WORK FOR ME, HOWEVER, AFTER READING SEVERAL POSTS REGARDING THAT BLACK ROLLER WITH THE LOCK PIN ISSUE BEING THE SOLUTION FOR SOME, I DECIDED TO PLAY WITH THAT IDEA. HERE'S WHAT I DISCOVERED - AND IT WORKED!!!! THERE IS A LITTLE ARM THING NEXT TO THE BLACK ROLLER THAT I "ACCIDENTALLY" PUSHED DOWN WHILE PLAYING THE ROLLER AND IT MOVED TO THE DOWNWARD POSITION - WHILE IN THE DOWNWARD POSITION, I POPPED A TAPE IN AND THE TAPES PLAYED - NO ERROR CODE - JUST ECSTASY!! I SCREAMED SO LOUD THAT MY HUSBAND THOUGHT I GOT HURT OR SOMETHING TRAGIC HAD HAPPENED. GIVE IT A SHOT - WHAT HAVE YOU GOT TO LOSE. I'M TRANSFERRING ALL MY 8MMS TO DVD AND GETTING RID OF THIS THING. GOOD LUCK - I HOPE THIS HELPS SOMEONE ELSE.

DEBBIE
Sun, 17 Feb 2008 18:17:38 +0000

OH AND BTW THE AFOREMENTIONED CAMERA IS A DCRTRV460 THAT I POSTED ABOUT - THE ARM NEXT TO THE BLACK RUBBER BEING IN THE DOWNWARD POSITION TO PLAY TAPES. PEACE OUT, DEBBIE

DEBBIE
Sun, 17 Feb 2008 18:52:46 +0000

I have a Sony CCD TRV118 camcorder and I keep getting the error C31-23. This appears three seconds after I start to record. I gave it the Wack Theory and it worked. The problem now is it is not recording anything. I see a view through the screen when I am recording but when I rewind to see what I've recorded it doesn't show anything. Can you help me?

Spoonman Al
Mon, 18 Feb 2008 12:06:19 +0000

Part number may be x or y 395 293 41.

herb fellows
Tue, 19 Feb 2008 02:58:50 +0000

Thank you all for the great help. Ahmad, thanks for taking the time to document this.
My comments, and hope they will help someone who is about to start looking into fixing this issue: I have a Sony DCR-TRV19. I was getting C31:23 and C31:22 errors. I opened the camera and could not find a loose or dislodged black rubber barrel. All the vertical posts were shiny silver so I figured my camera style was different. I cleaned things up, and touched all the components with a soft rubber point to ensure all was in place. None of that worked. I opened the tape and closed it many many times.. I shook the camera in hopes something would come out.. nothing would. I placed the camera under a bright table lamp and noticed a black rubber barrel wedged all the way to the right deep inside. Again, I am working from the tape opening.. did not take the camera apart. So, I used a paper clip bent at the end as a hook and grabbed that little sucker out. There was only one nice clean post it would fit on (does not have any sensors on top of it). It was on the right side as Ahmad showed in the pics. Found me an ink pen, cut a small part and tested and trimmed it to the right size. This was tricky, as I got the errors after I did all this.. the pen part was a bit too high.. I took it out and made sure it was flush with the barrel top. I tested the camera and it worked in VCR and camera mode. Things were still loose though as I was still able to slide the barrel and the pen piece with ease. So I took the pen piece out and got some glue on the inside of the hole of the ink pen piece.. I mean just a bit (less than 1/4 of a drop). I used a needle to apply the glue to the inside of the pen piece. I slid it back on and made sure the barrel still moved freely (I used.. forgive me for this.. crazy glue.. just remember, the glue is not necessary.. and needle top of a drop on the inside is all I used). so far it is working really nice. Hope it will stay that way. Best of luck to all and so nice to be able to benefit from the nice folks around the world who are willing to spend a few minutes to help other. Peace!

Khalil
Tue, 19 Feb 2008 17:38:18 +0000

I have a sony handycam modle #dcr-trv340 and I am getting a error code C:31:23 and don't know what the problem is. I had my camcorder outside last night recording the lunar eclipse and ran out of tape came inside to change the tape and i had it plugged in. when i went to close the tape in I unplugged it and the tape became stuck it did not close all the way, when I plugged it back in the tape closed and when I turned it back on my camcorder started to beep and then I saw the error code in the window flashing at me. Now I read the forme and nothing that you all have said is my problem the little rubber roller is fine plastic piece and all. What else could be the problem?

Michael
Thu, 21 Feb 2008 16:13:42 +0000

I've gotten error C:31:23 a couple times over the last year, and all it took to fix it was a good smack. Though, when smacking it doesn't work I will certainly look back to this site for a more detailed explaination on how to fix it.

Lisa
Fri, 22 Feb 2008 04:04:38 +0000

Hi, I justr tried the slap it and see method and it works, what a great resource the internet is!
11/04/2008

UK dude
Fri, 11 Apr 2008 10:19:58 +0000

i have an issue of c:31:23... and thank god, theres a lot of good hearted people who share their experiences... Now i don't have to pay too much for the repair... anyways,my camera is Sony VX 2100... its one hell of a cam... peace to everyone... GODBLESS

paulo of philippines
Wed, 23 Apr 2008 13:48:45 +0000

I HAVE AN ERROR CODE(C31:22) WITH MY SONY CAMCORDER DCR-TRV350 NTSC SO I MUST EJECT THE CASSETTE AND PUT IT AGAIN ,REMOVING BATTERY ....SAME PROB HOW CAN I RESOLVE THE PROB ..THANKS

FATEH
Mon, 12 May 2008 17:50:25 +0000

Saw the post on replacing the lock pin on the Sony pinch roller assembly. Wish my problem was so straightforward! My DCR TRV250 camcorder is giving me the infamous C31:23 error code. I have read most of the interweb repair advice from slapping to replacing the lock pin. If I may I'd like to describe what's happening with mine in hopes someone may be able to offer some advice on fixing it.

I put in a tape.

It goes into standby mode.

I press play but for some reason it goes into FF.

Everything then stops, beeping sound begins, error code appears.

I hit eject, tape holder mechanism comes 1/2-3/4 way out, stops.

I press "reset" button, tape fully ejects.

I have examined all moving parts but see no damage or loose settings. I have also removed and reinstalled the battery (hundreds of times now!).
Yesterday the machine actually taped for a while and played back (a new tape) but that seems like just a sweet memory to me now.

Any ideas on possible repair are GREATLY appreciated!

Fred Hedgecoth
Wed, 04 Jun 2008 14:08:37 +0000

Being a model car builder I fished out some platistruct tubing that was the perfect diameter and I cut a really small piece and inserted it inside the roller with a little glue between the outside of the plastic and inside of the rubber wheel and slid it on the pin and volia - the error code is gone and all is well. This took all of two minutes to fix. You guys are awesome.

Rex Turner
Sat, 12 Jul 2008 19:53:55 +0000

I have read and tried to understand all of the above and the 31:23 will not go away. Problem: the error code flashes at me and when there is a tape it, it makes a horrible grating type of noise. When I take the tape out, i find that the camera has pulled out the film a bit. I have located the rubber wheel thingy and the white piece. I have tried to take the black roller out. It did not pop out and i was afraid to force it. Help? Suggestions? Ideas? All much appreciated. 2 small children (4 and 1 1/2) involved in summer water fun and such... and me with no camera.
Grrrrrrrrrrrrrrrrrrrrrrrr!

jamr
Thu, 17 Jul 2008 17:17:02 +0000

Thank you very much to Ahmed Jasim. I had that 31:22 error and after looking at your pictures and the diagram, I looked at the white cap and saw it was out by just a little bit. I pushed it back in and it was fixed. I thought I was going to have to spend a ton of money to get it fixed.

Thanks again and be safe my friend and I hope everything goes well in your country.

Mike
Wed, 30 Jul 2008 21:52:50 +0000

Regarding error code 31:22 I had this problem and the solution was to make sure I used a Hi8 tape rather than a standard 8mm tape. Hope this helps.

steve aenthaneay
Sun, 24 Aug 2008 07:15:12 +0000

i have a sony dcr-trv250, and after four years i finally got an error code C:31:20, what exactly is this and how can i fix it. any help as always would be greatly appreciated, thank you

brandon
Wed, 27 Aug 2008 04:37:16 +0000

Just picked up a TRV-950 off of Ebay for a decent price and after receiving in the mail, kept getting a C31:23 Code whenever I would try to play, rewind, or FF a tape. Thanks to you , I found White insert missing and finally found a piece of heat shrink tubing rhe correct diameter and now works like a charm. Thanks Ahmed, you saved me a bundle !!! Now if I could find the exact size replacement tubing, my mind would be more at ease !!!

Chas.
Fri, 05 Sep 2008 04:06:50 +0000

SOLUTIONS IN SPANISH
en este foro lei que habia que golpear la camara conla mano firmemente para que funcionara, y lo probe y empezo a funcionar maravillosamente despues de dos años

GERMAN
Fri, 12 Sep 2008 12:06:01 +0000

Thanks Ahmed and Jason, for your analysis of the problem and the illustrated instructions.

I had been having Error messages off and on for some time, which I usually solved by taking out the cassette and whacking it against a flat surface (an old trick from using audio cassette recorders). This time, after not using my PC9 Handycam for a month and a half, nothing seemed to work.

After studying Jason's pictures and peering into my machine, I figured I was missing not only the white plastic part but also the black rubber part. I shook the unit a whole lot with the door open and the white part appeared against the red table cloth. It was so small I might not have noticed it had it not been for the pictures. Encouraged, I continued to shake a whole lot more, but nothing else appeared. Dismayed, I went and sat down on the living room rug in front of the TV where I had been hoping to watch the videos of my summer vacation. And lo and behold, by some miracle I spotted the rubber roller in the nap of the rug.

Not having any proper tools at my current location, I used wooden matchsticks held by a clothespin and a kitchen knife to put the rubber roller and the pin over the spindle and a kitchen knife to tamp them down. I'm in business again.

The advice of another contributor, to always check the status of the white holding pin when changing tapes, is probably very good. And our general opinion that Sony could treat its customers better is very true.

Lathrop
Tue, 07 Oct 2008 04:33:00 +0000

My sony FX1 is give me a error code C:32:22 but only TDk miniDv60 Me(one single records) with Maxell DVM60ME(4 time records)and TDK 60 Digital Master(7 time records) is works.where is a problem? Tape or rubber roller? Thanks

Peter Dema
Tue, 07 Oct 2008 20:19:15 +0000

Ive tried whacking it. Ive tried everything. I have a DCR-TRV17 and I need to find a diagram of where something could be wrong...

F*** SONY!!!

Adam Gabor
Wed, 15 Oct 2008 02:04:01 +0000

I also am posting to say "Thank You" to Ahmed Jasim. The roller in my DCR-TRV18 was also loose inside the camera. The white retainer tube was nowhere to be found. I went with the BIC ink tube fix. I found that the ink tube that worked the best was from the inside of a pen where you can press the button on top to make the tube come out. The kind of Pen that has a cap seems to have too large of an ink tube.

Now unfortunately before I found this fix, my camera ate the tape that had the birth of my third child on it. The tape is in tack, however there is about a 15" section that is pretty crumpled up. I am hoping to real the tape in and try to play it.

Thanks to everyone here for their suggestions.
Tom M

Tom M
Fri, 31 Oct 2008 03:56:02 +0000

Add my thanks to Ahmed Jasmin! I found the roller inside my Sony TRV-350 and re-seated it as Jasmin suggested. All Better! Rather than a plastic tube from a ball point pen for the lock, I used a small piece of rubber tubing from an eyeglass repair kit. thanks again, Jasmin,
Tom

tom
Mon, 03 Nov 2008 18:46:40 +0000

My very old Sony TRV608 is giving me error code 31:20 when I try to eject the tape. It makes a beeping sound, the tape comes up just a tiny bit then it stops. This is so frustrating. Please help.

Maddy
Sat, 15 Nov 2008 07:27:59 +0000

I have a TRV0608 too with the same problem. First I get a 31:20 then a 31:22 code. The tape has been stuck for months. When you press eject the tape comes part way up then goes back downn again without ejecting the tape, then the codes come up. Anybody out there with a solution for this problem besides sending it out and getting ripped off? Thanks

Mike
Thu, 18 Dec 2008 02:14:27 +0000

I got the error C:31:23. I tried to check the black roller using a clipper and in the process the takeup guide roller came out of the guide arm. When I tried fixing it I found the pinch(black)roller needed to be aligned with the guide roller... with great difficulty put it all back togather and loaded the tape. It loaded correctly and the error was gone, but when I took the tape out the guide arm did not retract correctly and again the guide roller was hanging and finaly came out. I did this three time now and getting frustrated. Any one has any idea how to fix the retraction of the guide arm. what am I missing...did a lot of study and hard work .. but all in vain.. but I know this can be fixed.. Help!!

ajay
Fri, 26 Dec 2008 03:00:12 +0000

This was a very helpful discussion.

My camera got the 31:23 code on this past Christmas morning so I missed all of that unfortunately. I found beating on the camera (DRC-TRV340) to not be helpful in my case.

Thanks to the pictures provided of where the part should be and what it looks like I was able to see the roller was missing from the post. After an hour disassembling the camera, I found the roller and the white locking post stuck deep in the internals. I extracted them, reinstalled them on the post and then reassembled the camera. That fixed the problem.

Real pleased with the end results. That said I will definitely be looking to off-load all my tapes to hard drives and DVDs.

Frustrated No More
Wed, 07 Jan 2009 15:58:03 +0000

i have the same problem of 31 23. and i can resolv it with a big slap on down base of the camera .the model is tr640e.

tomas
Thu, 08 Jan 2009 16:08:20 +0000

Awsome job!!!!!!!!!!!!!! it worked for me....

James Bond
Sat, 31 Jan 2009 07:18:32 +0000

Ahmed, You are the best! Your pictures helped me fix my video camera. From the looks of it, you have helped so many people with this one that you don't need to do another good thing in your life.

Thanks, Scott

Scott Tougas
Sat, 07 Feb 2009 02:23:35 +0000

I hate to throw a spanner in the works and Im glad most of you have solved your Error Code C:31:22 problems! However I am having the same symptoms- The eject symbol on screen and the code. However, looking at the roller it is in the proper position and the white lock is in place. I have watched the roller move when I close the tape case and it seems to be moving fine. All other functions are working ok- screen etc. Any advise??? Was really hoping what youdid to yours would work on mine but that doesnt seem to be the problem! Thank you.

Caroline
Mon, 16 Feb 2009 17:11:38 +0000

Hi there guys please ignore my stupidity on not knowing what things are called so sorry in advance..Ok here we go i have borrowed my brothers sony handycam dcr-trv130e i tried looking at a old tape i have before i use it to record over.All i got was the dreaded blue screen so i just tried recording it brought i picture out but on the left hand side three big lines going through the screen and the sound is dreadful. so i checked the net solution seemed in the head cleaner so i bought one tried it still no joy so i took the casing of the side of the tape loader to inspect closer on inspection i noticed something stuck at the bottom i grabbed it and its a little roller with another roller on it i don't no what its called but theres another on the other side and its the thing that grabs the tape and takes it to the heads someone said its a taper arm but i have searched no luck anyway nothing looks broke its like its just fell out so i tried to put it back in but theres to much play in it.so i no it will fall off again so i was wondering if someone could help me get this little roller back on thanx in advance take care guys...jimmy p.s cant get pictures coz the camera dont work lol but if you need em i will borrow one and get them to you

Jimmy
Fri, 13 Mar 2009 21:54:45 +0000

Hi there guys please ignore my stupidity on not knowing what things are called so sorry in advance..Ok here we go i have borrowed my brothers sony handycam dcr-trv130e i tried looking at a old tape i have before i use it to record over.All i got was the dreaded blue screen so i just tried recording it brought i picture out but on the left hand side three big lines going through the screen and the sound is dreadful. so i checked the net solution seemed in the head cleaner so i bought one tried it still no joy so i took the casing of the side of the tape loader to inspect closer on inspection i noticed something stuck at the bottom i grabbed it and its a little roller with another roller on it i don't no what its called but theres another on the other side and its the thing that grabs the tape and takes it to the heads someone said its a taper arm but i have searched no luck anyway nothing looks broke its like its just fell out so i tried to put it back in but theres to much play in it.so i no it will fall off again so i was wondering if someone could help me get this little roller back on thanx in advance take care guys...jimmy p.s cant get pictures coz the camera dont work lol but if you need em i will borrow one and get them to you

Jimmy
Sat, 14 Mar 2009 00:46:59 +0000

I had this same error message problem with my camcorder-- I got a C31:23 blinking message when I tried to rewind a hi-8 tape. So I took the end of a ballpoint pen and prodded the black plastic reel back out further on its stem. I suspect that the problem will recur because I didn't add the white cap referred to in another post, but for now the camera does work.

(I have since purchased an internal hard-drive camcorder!)

Good luck!

ANNE
Mon, 23 Mar 2009 02:43:57 +0000

Thank you so much all of you. I tried the banging, smashing it seemed to work, but only for a few seconds.
When i banged it without a tape the black rubber wheel came off.
My white plastic must have fallen off earlier.
I took a peace of electrical wire insulation, that was the right size.
Now it works fine.

Andreas
Sat, 04 Apr 2009 02:15:05 +0000

Hi, I know this string started a couple of years ago. I am having the same problem, but like Caroline above, my parts are all present and accounted for. When I force the tape out, the ejection mechanism work fine. If the tape is in, it jams again and gives me the C:31:20 error code.

sharon
Fri, 10 Apr 2009 18:05:13 +0000

These error mostly of the Reel (supplu and take up) Speed detection Senors.
If its possible Try to clean the sesor of the reel Spool Frequency generator sensor

Rajesh kumar
Sun, 26 Apr 2009 15:18:21 +0000

my trv245e was showing c:31:22 error, so tryed the "slap" and wow it really worked !!!
ive checked the said roller and seems ok at the mo but will be watching it carefully !!! will give the whole thing a good clean will let you know how long the "fix" lasts !!

this is the most worthwhile thread ive ever been on, well done to all who have contributed !!!!!!!!!!!!

Chris Ablett
Sun, 14 Jun 2009 08:19:20 +0000

Thank you very much Ahmed Jasim ! I had that C:31:23 error on my PC 101E. I had found that weird litte roller but couldn't figure aout how it was supposed to be fixed (the white part had fallen porbably lost... I took the WD40 spray tube and it is working properly now !
Thank again for the pics.
Fred

Fred
Sat, 27 Jun 2009 13:39:57 +0000

I took a can of air duster, bought at a computer store, blew into the tape mechanism area (no tape), and voila! error went away, I'm going to cross my fingers and buy a fresh can for the next time.

Error C:32:31
Sun, 16 Aug 2009 20:30:24 +0000

Ahmed's post 09/01/2007 has fixed C:31:23 for me - my black roller was missing completely when I looked. It was tucked away at the back of the camera with the white "locking" tube still in it. I managed to shake the two out and re-assemble with tweezers in 1 minute. Brilliant advise!
Thanks!

John Richardson
Wed, 19 Aug 2009 10:27:45 +0000

hOLA, SOY ESPAÑOL Y TENGO EL ERROR C 31:20, PODRIA UD DECIRME COMO LO ARREGLO? GRACIAS
--
HI, I'M SPANISH, AND I'VE A RTV250 WITH DE FOLLOW ERROR: C 31:20 CAN YOU HELP ME?

DEPSAD
Sun, 13 Sep 2009 02:56:14 +0000

I have a SONY TRV330 Digital Camcorder. It started the C:31:22 error out of the blue. Not after I changed the tape. Not after I dropped it. Just went to turn it on one day to record something and "da ding,da ding...da ding..."
Fuck Sony, Fuck Sony, Fuck Sony. A $699 purchased wasted.

Phil
Sun, 20 Sep 2009 23:15:27 +0000

Forum helped me in instantly solving my c 31: 23 error problem . Hats off.

Paramjit
Sun, 27 Sep 2009 04:24:21 +0000

Having the same problem with the rubber wheel. It was stuck and thus so was the tape. I took off the plastic cover over the tape port mechanism. I used the DC adapter for power rather than the battery while I worked on it. I managed to lightly rap on the side of the recorder, which allowed the tape mechanism to slide out just enough for me to see the rubber wheel. With tweezers I was able to remove and re-install the rubber wheel. I stripped some flexible rubber wire insulation off of some wire, applied a little Lock-Tite inside the rubber insulation and pressed the rubber insulation on to the rubber wheel stand or pole. I used a Q-tipj to clean the head and applied some WD-40 to the moving joint areas. The tape mechanism now opens and closes with no problem and the error code went off.

Crockett
Tue, 22 Dec 2009 14:37:23 +0000

I've looked in my camera to compare with the photos that Ahmed has provided to find that not only is my white lock missing, my black rubber wheel is missing. Can anybody offer a replacement for the wheel?

Chris Beliveau
Thu, 31 Dec 2009 00:27:46 +0000

thanks for the rubber ball fix it just got done but now another error has occurred now i can play back the take in the vcr mode as in when i play it back i cant see anything its just a blue screen and no recorded video is displayed i think my cam head is not reading the tape now any help ?????

jamal
Sun, 17 Jan 2010 09:00:51 +0000

Hi. I have problem the camera . I'd like to know what does the mean C31 22.
separately C31 - I did understand, but the firstly i need to know what does 22 (after C31) meaning???
pls let me to know asap.

I really will be happy.

A.

Aryna
Mon, 25 Jan 2010 14:44:26 +0000

My camera hit the floor off my foot and out rolled the black rubber wheel and white lock. Then error C31:22. Ahmed's pictures and diagram above helped my fix this very quickly. Good stuff Ahmed Thanks!

Sal

Sal
Tue, 26 Jan 2010 02:43:16 +0000

Exploded view from the service manual attached!
Part number X-3951-303-1

You're welcome....

Attached File: sony11111.pdf (89 KB)

Lou
Sun, 21 Feb 2010 21:49:15 +0000

Vielen Dank Ahmed,
hatte das selber Problem aber Dank deiner Bilder ist es behoben.

anonymous
Mon, 22 Feb 2010 17:59:06 +0000

Hi,

This thread was such a help, after smacking the living s$#@ out of my corder I scrolled down and saw the picture posted and realized that my pinch roller rubber cover is completely missing. I will try and call Sony in the morning. Thanks yall!

Dominic
Mon, 29 Mar 2010 02:02:06 +0000

gracias....wow AHmed..gracias so much was about to throw it away...thank u for u humbleness n helpful wisdom... vero

vero
Tue, 06 Apr 2010 10:10:17 +0000

I WAS HAVING ALL THIS PROBLEMS AND THE SOLUTION WAS TO PUT BACK THE SMALL BLACK RUBBER INSIDE THE MECHANISM AND SECURIT WITH THE LITTLE WHITE PLASTIC CUP AS AHMED JASIM SAY AND HAVE PHOTOS ABOVE .
THANKS ALOT AHMED !!!! ;) :) :)

LEFTERIS
Sun, 30 May 2010 20:53:13 +0000

I am losing faith in Sony, first my LCD failed, now C31 error, whats next. sony quoted 600 bucks to repair. I have this old JVC, 15 years old and still works 100%. I am going to stick with JVC and Cannon.

sage
Thu, 08 Jul 2010 10:58:54 +0000

i reattached the rubber wheel and now my camera works fine in vcr but when i switch to camera the no tape and eject icons come up any suggetions

Matt
Tue, 20 Jul 2010 15:26:08 +0000

Many thanks dear Ahmed for your useful illustration, this was really a simple problem that coسt people a lot of time, efforts and money. God bless you and Iraq
جزاك الله خير

Ammar Al-Qaraghuli
Fri, 24 Sep 2010 11:07:26 +0000

Can I just say THANK YOU Ahmed and all of you who put comments about these parts falling out. I just spent a total of 12 minutes taking the three screws out of the top plastic cover of my DCR-TRV350.
AND THERE IT WAS!!!!! Staring right at me!!!!! That little rubber barrel piece wedged in the corner. I spent HOURS of time with Sony on the phone and searching the internet for a way to get our camcorder "fixed". We just came home tonight from comparing new camcorders as we are tired of missing so much of our kids activities and an upcoming vacation. Stupid frugal me, I was having a hard time departing with a pen to use a tiny piece of the ink tube. Then I compared the costs of the parts and repair charges,( about $100-$200), to the fraction of the piece of pen that I was about to destroy, I realized that IF this worked the memories wil be priceless!!!! As I wipe the tears and say a prayer of thanks and God Bless to you all, I'm going to record my family while they sleep,as they have no idea of our huge accomplishment.
THANK YOU,
Tracey

tracey
Sat, 02 Oct 2010 05:17:59 +0000

I had the roller but no plastic sleeve for my Sony TRV19. I found a piece of small insulated electrical wire and stripped the insulator off of about 2 mm of it. I squeezed the insulator on that little axel and it did the trick.

Chris
Sun, 21 Nov 2010 22:15:42 +0000

I BOUGHT ONE WHAT I DID WAS SHAKE IT
THERE WAS A ROLLER MISSING STILL INSIDE I PUT IT BACK ON THE EMPTY
PIN INSIDE OF THE CAMERA FACING THE
LENSE. THE ROLLER ALLOWS THE MOTOR TO
CONTACT THE TAPE WHICH IS WHY IT GETS
A C1 ERROR MINE WORKS NOW. ITS A MISSING PART.

Thomas Van Horne
Sun, 30 Jan 2011 06:43:55 +0000

I have a Sony CCD-TRV118 560X and mine was flashing the C:31:22 and when I shook the camera a screw came off of the side right lower corner near where the tape goes in. When I put the screw back in, it stopped. I think that code might just mean that SOMETHING is lose, not necessarily the round rubber tube as above. (Mine was fine)

Lora
Tue, 01 Mar 2011 19:11:49 +0000

I don't know if anyone is monitoring this still, but I found it extremely useful. I wanted to share that I had a similar problem with my Sony DCR-HC30 Mini DV Handycam Camcorder. The rubber tube was nowhere to be found. I called Sony, and the rep was very helpful. We identified the part as a "pinch arm assembly", which was part no. 768 on a page from the repair manual that he emailed me. (The page is labeled "5-1-8. LS Chassis Block Assembly".) The part arrived in the mail ($25.27 for the part, plus $6.95 shipping and handling, plus $1.58 local sales tax, equals $33.80) in a box labeled "X-3952-934-1" and with a bar code with the following underneath: DCR-TRV22K. The packing list listed the part as X39529341 "Arm Assy Pinch". Short story: it worked, and my camcorder is back in working order. I hope this helps!

nboston123
Sat, 23 Jul 2011 01:03:30 +0000

My TRV250 quit working on a vacation of all places. None of the controls would work, and the Eject symbol and the code C:31:22 started flashing on the screen. When I got home, I Googled "Sony Handycam C:31:22" and found this forum.

For me, Ahmed's solution worked. I looked in the cassette compartment (with the tape out) and found the black roller wedged behind (above) the record head. It took a little shaking to get it loose. I couldn't find the smaller locking tube. That obviously fell out on top of Lookout Mountain when I opened the camera to see if swapping tapes would solve the problem. At least I know where to go to look for it. Well . . . not really. I am glad that the roller stayed with the camera!

I replaced the locking tube with a short piece of a ball point pen tube and the camera works fine now. I had to crimp the tube some in order for it to grip the roller shaft so a piece of tube with a smaller inside diameter is called for. I do plan to carry this ball point pen and a pair of needle nose pliers in my camera bag now for field repairs.

Ahmed, thank you for an excellent solution. No telling how much money you have saved me. Karma will reward you!

Bill

Bill
Wed, 21 Sep 2011 04:29:22 +0000

I have a problem comcoder Sony DCR-HC54E 31:23 error. I observed that the roller as ahmad tell is on right place (caused by different model? I do'nt know). please let me know how to fix it.
thanks

Attached Image:

IMG00330-20120131-0056.jpg

Heru
Mon, 30 Jan 2012 20:51:07 +0300

If your roller has fallen off and you can't find it then banging on the camera won't help! Banging on it only helps if the roller is still there and just needs to be moved back down on the post. If yours is missing, you need a new "Pinch Arm Assembly".

Hopefully you can remove the roller from the new one and put it on the old one inside the tape drive. If not you have to remove the whole arm and replace it which would be way harder.

You can find the one that fits the DCR-TRV19 and 22 here:
http://www.darntoothysam.com/products/Sony-DCR%252dTRV19-Cam . . .

Hope this helps!

Attached Image:

Sony-DCR-TRV19-Roller-1.jpg

Mark B.
Mon, 20 Feb 2012 20:21:58 +0300

Quote:

I've concluded that sony dealers don't have the white lock in their stocks as a spare part. you have to make one by yourself.
The diameter of the spindle axes is exactly one millimeter. you should find a copper tube of 1 millimeter inner dimmension (from a hardware store) cut a 3-4 mm of it (usually it comes in 1 meter long) use a mini disc drill to cut it, do not use a cutter because it will deform the tube. if you find the made lock loose and do not grip around the spindle then you should enter a tailoring needle in the made lock then poor a little bit of "patex" cement on its extreme and pull it out again. now the patex glue should fill the made lock. push the lock into its supposed position. use it the next day.

N.B: you don't have to disassemble the camera, just disassemble the door plastic cover"

Response: I don't recommend a copper tube, for several reasons:

1) in order to cut it you're gonna have to use a Dremel and a cutting disk or something, which will cause abrasions on the end of the copper tube. And, the Rubber Black Roller (the capstan pinch roller) is made of plastic down inside. As the black roller spins it will come up against the copper tube and run against it like a lathe running on a piece of material. It will slowly (or not so slowly) etch away the inside of the pinch roller, right where it slides down on the shaft, ultimately eating it away.

2) You'd have a very hard time getting a copper piece of tubing to slide down on the shaft, without pushing down very hard. And, if you push down hard, you'll bend the arm that hang out blindly into the air, that has the shaft and black roller on it. Then the black roller will sit at an angle.

-----

Definitely use a tight fitting piece of plastic tubing (like the ink pen tube that many have talked about).

I ordered the piece from Sony Parts (about $10, and about $10 in shipping....$22 total), which included the entire arm, black roller, and plastic retainer. Of course, all I need was the plastic retainer. I would like to note that the new "white plastic retainer ring" is actually gray plastic now. I'm betting that Sony went to a different type of plastic to get it to stay on better now.

-----

Finally: When the new assembly arrived, I took it apart piece by piece in order to use the new "gray plastic retainer" inside my camera. I was surprised to see that there are two subminiature nylon disks one immediately below the black roller, between it and the metal shaft inside the camera. And, another between the black roller and the white/gray plastic clip. And, these had a minuscule amount of white lithium grease on them to lubricate them.

I would recommend having these nylon disks in the assembly and the tiny bit of white lithium grease. Because, they allow for a slip-surface between the black roller and the shaft, and between the black roller and the white/gray tube looking retainer.

I dropped my camera on the floor (that would be much like the "banging" recommendations that many have made here online). And, seconds later my son said, "Dad, what is that?" Laying on the floor was my black roller. The impact had caused the white clip to come off the shaft, and the black roller to come out of the camera.

I do not know if the two tiny nylon washers were ever inside the camera originally. OR, whether Sony started including them on the replacement assembly to make it operate better.

But, I'm relaying all this info to all of you, to say, "Please don't BANG your camera". There are many delicate mechanisms inside camcorders: black roller, white retainer clip, tape alignment rollers, the flying record/playback heads, tape load and extract mechanisms with tiny plastic teeth.....and oh my goodness, very delicate optical mechanisms on the lense...whether you have optical stabilization or digital image stabilization) - banging is not a good idea! Banging should never be a solution. And, in my case, the medium bang it got when it fell off my computer desk onto the floor, was just the bang it needed to make that black roller and white retainer tube simply come off!!!!

Rob
Sat, 01 Sep 2012 22:25:05 +0400

I was getting the C:31:22 error, which just came up after taking the camera out of storage. It would appear when i tried recording, playing or rewinding the tape. After looking at this thread I just tried resetting the camera to factory and now it works. Rewind, play and record.

Roy
Wed, 05 Sep 2012 13:12:15 +0400

Ahmed. You have no idea how much you have saved our cameras. My Sony PD 100 failed me this Easter when I together with a gang of touring photographers went exploring caves and tunnels in undiscovered tourist destinations. I just fixed the camera with the pen tube! I suggest we all send a minimum of $10 to Ahmed to get himself a cola drink for his free support to us. Ahmed please let me know how I can send mine. I live in Ghana; West Africa.

Amigosten
Fri, 26 Apr 2013 12:06:17 +0400

I need a camera head for my Sony PD150, Anyone with an idea about the price and where to get it. Which other camera uses same type of head if I want to improvise.

Amigosten
Fri, 26 Apr 2013 12:14:18 +0400

Just fixed my Sony TRV 608 handycam with the instructions on the posts. I just bought it used to get video off old hi8 tapes. It was heading for the recycle center before I found this website. 8 1/2 years later and the instructions are still useful! Many thanks.

Ben
Mon, 06 Jan 2014 20:52:19 +0300

Ahmed, is right. I saw these parts suddenly out and didnt realize they came out of my camera. Struggling to solve the C 31 problem i got here and i made it to troubleshoot it thanks to his images. Thanks!

Tasos
Tue, 03 Mar 2015 21:15:51 +0300

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.

TrackBack

Send Ping | TrackBack URL | Spam Control

Title: Error Code C:31:23?
Weblog: Camera Hacker
Tracked: Mon, 8 Aug 2005 10:30:23 -0700

Title: DCR-TRV350 tape wont eject C:32:11
Weblog: Camera Hacker
Excerpt: My PC110 has been showing the error C:31:22 and C:31:23 on and off intermittently for the past 6 months. It is New Year's Eve and the camera did not want to record again! I read the comments on this forum and smacked it 2-3 times as Debbie suggested. I had no luck. If anything, things got worse (or . . .
Tracked: Thu, 01 Jan 2009 21:34:48 +0000

Add Comment

Spam Control | * indicates required field
Your Name: *
E-mail:
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 7 - 4?
Click button only once, please!

Messages, files, and images copyright by respective owners.